1

I have been working on this project for at least 4 years; I left it alone for maybe the past 2 years, and when I tried to compile it again after updating all my latex packages, the footnotes in Devanagari (Indian) and Tibetan script do not appear. All of the English text does appear, and the Tibetan/Devanagari text in the lemma does appear; it is only the Asian scripts within the body of the footnote text that do not appear.

This bug is triggered by using the \numberlinefalse command. If this command is left out, everything works normally.

The bug also only happens if the file uses reledpar to create a dual-text edition (in my case, with left and right columns).

This wasn't happening the last time I compiled the project using an older version of latex (about 2 years ago)

Minimal Working Example

\documentclass{article}

\usepackage{reledmac}

\usepackage{reledpar}

\usepackage{fontspec}

\usepackage{polyglossia}
\setmainlanguage{english}
\setotherlanguage{sanskrit}
\setotherlanguage[numerals=false]{tibetan}
\newfontfamily\devanagarifont{Nakula}
\newfontfamily\tibetanfont{Jomolhari}

\begin{document}

\numberlinefalse

 \begin{pairs}

\begin{Leftside}

\setstanzaindents{0,0,0}

\beginnumbering
\autopar

\devanagarifont
\begin{sanskrit}

\stanza
\edtext{महा}{\Afootnote{माद्; \textenglish{A}}}भिज्ञापरीकर्म अविवादेन देशितम्।&
विवादे यस्तु चरति नोद्गृह्णन् स विमुच्यते॥१॥\&

\stanza
अभिज्ञा तस्य \edtext{सा}{\Afootnote{स; \textenglish{A}}} प्रज्ञा बोद्धं ज्ञानमचिन्तियम्।&
उद्ग्रहे यः स्थितो भोति ज्ञानं तस्य न विद्यते॥२॥\&

\stanza
बहवो ऽचिन्तिया धर्मा ये शब्देन प्रकाशिताः।&
यस्तत्र निविशेच्छब्दे सन्धाभाष्यं न जानति॥३॥\&

\end{sanskrit}

\endnumbering

\end{Leftside}

\begin{Rightside}

\setstanzaindents{0,0,0}

\beginnumbering
\autopar

\tibetanfont
\begin{tibetan}

\stanza
།མངོན་ཤེས་ཆེན་པོ་ཡོངས་སྦྱངས་པ། །\edtext{རྩོད་}{\Bfootnote{ཙོད་; \textenglish{B}}}པ་མེད་པར་བསྟན་པ་སྟེ།&
།རྩོད་པ་དག་ལ་གང་སྤྱོད་ཅིང་། །འཛིན་པར་བྱེད་པ་དེ་མི་ཐར། ༡\&

\stanza
།མངོན་ཤེས་དེ་ཡི་ཤེས་རབ་སྟེ། \edtext{།སངས་}{\Bfootnote{སང་; \textenglish{B}}}རྒྱས་ཡེ་ཤེས་བསམ་མི་ཁྱབ།&
།འཛིན་པ་ལ་ནི་གང་གནས་པ། །དེ་ལ་ཡེ་ཤེས་ཡོད་མི་འགྱུར། ༢\&

\stanza
།གང་དག་སྒྲ་ཡིས་བསྟན་པ་ཡི། །ཆོས་རྣམས་མང་པོ་བསམ་མི་ཁྱབ།&
།སྒྲ་དེ་ལ་ཡང་གང་ཆགས་པ། །དགོངས་པའི་བཤད་པ་མི་ཤེས་སོ། ༣\&

\end{tibetan}

\endnumbering

\end{Rightside}

\end{pairs}

\Columns

\end{document}
  • As it is a bug, it would have been better to open a new issue on github... – Maïeul Mar 28 at 8:46
  • I have opened a new issue. – Paul Mar 29 at 2:15
1
  1. With your MWE, I get Package reledmac Error: You have not defined the indentation for the line 3. and Package reledmac Error: \pstart encountered while another \pstart was in effect.. That is because you don't close properly your stanza, using \& for the final line of verse.
  2. \linenumberfalse and critical footnote does not make senses, as critical footnotes refer to line number. \linenumberfalse was added for people who want parallelel typesetting without line numbering. If you don't want to print the line number in margine ask to print it after a big number of line. For example \firstlinenum*{100000} in your preamble.
  • OK, I have used your suggestion for the line numbering, and it works fine. For some reason the slashes got deleted in my MWE, I have added them back in. I understand the purpose of \numberlinefalse; in the verse section of my edition I refer to the text by verse number instead of line number in the apparatus, therefore the line numbering on the margin is superfluous. Thanks for your help – Paul Mar 29 at 2:13
  • but, the verse number and the line number, with \stanza, are the same things. I don't understand your point. – Maïeul Mar 29 at 7:51
  • One stanza in my edition takes up two lines, so using the line numbering in the margin there are two lines per stanza. The way I set it up was to refer in the apparatus to the number and quarter of the stanza, not the line number. So "stanza 1" would take up two lines, with four quarters (two quarters per line). If I want to refer to something in the third quarter ("c" out of quarters a, b, c, and d) of stanza 1, I use "1:c". If I were using line numbers to refer to the same passage it would just be "2" for "line number 2." For the type of verse I am doing this way is more precise. – Paul Mar 29 at 17:09
  • Although the "line number annotation" option that you describe here may have worked (tex.stackexchange.com/questions/468970/…). It was so long ago that I wrote this that I can't remember why I did it they way I did it. – Paul Mar 30 at 3:36
  • please send me a email with your problematic explained. Or open a new question – Maïeul Mar 30 at 13:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.