I have TeXLive 2017 installed on Ubuntu under ~/.local/texlive/2017 (the canonical single-user equivalent of /usr/local/), and would like to do the same for the 2018 version.

I've always used the "expert" GUI mode, but it's not possible to enter the desired paths, because the GUI forces you to use a file section dialog that refuses to show hidden folders. I also tried the "wizard" GUI mode, which has the same behavior.

Has something changed in the 2018 installer?

Note: as I was writing this I discovered that in text mode the installer will automatically detect the previous installation and offers to install the new version alongside it, but the GUI doesn't do this. Presumably I could type in all the paths manually in text mode as well, but I'm fairly certain that I've never used it.

1 Answer 1


Apparently something has changed. I found my old TeXLive 2017 ISO file, and the GUI installer in that version used manual entry for all paths. So for now, it looks like the text mode installer is the only option.

  • there were a nuber of recent changes but by setting some environment variable (too many to test without your platform) you may be able to over-ride behaviours see tug.org/texlive/doc/install-tl.html
    – user170109
    Commented Apr 14, 2019 at 21:19
  • You're referring to TEXLIVE_INSTALL_PREFIX and such, right? That's good to know, but for non-technical users that's considerably more arcane than just entering the paths using the text installer. The problem is the new widget in the GUI. Commented Apr 15, 2019 at 0:31
  • I dont know if any presets may affect gui during install e.g. exposing .dotted dirs. (generally windows GUIs hide user locations without any reference to where temp or "program files" will be located, hence lots of problems with user dirs) but I have not tested any such settings personally since I run portable (trying to always keep files more simply in the open) I may try the new 2019 GUI later this month to see what impact that may have
    – user170109
    Commented Apr 15, 2019 at 0:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .