1

I can't find why the page-numbering after a chapter (or even toc) in front-matter switches to arabic. I would appreciate any helps and hints to fix this.

Here is my (edited) code:

\documentclass[
10pt,                                
DIV=calc,                           
parskip=half,version=first,             
%headsepline,                   
%numbers=noenddot
]{scrbook}


\usepackage{scrpage2}
\usepackage[includehead=false, includefoot=false, paperheight=240mm, paperwidth=170mm, 
twoside=true, left=25mm, right=20mm, 
top=35mm, 
bottom=20mm]{geometry}



\usepackage[format=plain, font=small, font=it, labelfont=it, labelfont=small,
width=12.5cm, indention=.5cm]{caption}


\usepackage{siunitx}
\usepackage[LAE,LFE]{fontenc}
\usepackage[english,greek,farsi,ngerman]{babel}
\usepackage[utf8]{inputenc}
\usepackage{latexsym,amssymb,amsfonts,amsmath}
\usepackage{chngcntr} 
\usepackage{microtype}
\usepackage{lmodern}



\usepackage{graphicx} 
\usepackage[authordate-trad,backend=biber,natbib]{biblatex-chicago}
\usepackage[T1]{fontenc}

\usepackage{subcaption}
\captionsetup{compatibility=false}
\usepackage{float}
\usepackage{setspace}
\usepackage{adjustbox}
\usepackage{tikz}
\usepackage{tocstyle}
\usetocstyle{standard}
\usepackage{tocbibind}
\usepackage[final]{pdfpages}
\usepackage[]{hyperref}



\begin{document}


\frontmatter

\begin{titlepage}
%-----------------------------------------------------------------------------------------
\centering

\vspace*{1cm}

\begin{bfseries} \Large
Something\\
\end{bfseries}

\vspace*{2.5cm}

Vom Fachbereich Something\\
zur Erlangung der Würde eines\\
Doktors der Philosophie (Dr. Phil.)\\
genehmigte Dissertation\\

\vspace*{2.5cm}

vorgelegt von\\[1.3ex]
\textbf{\large Something}\\[1ex]


\vspace*{2.5cm}

\begin{tabular}{r@{\extracolsep{1em}}l} 
Hauptberichter: & Prof. Dr. Something\\
Mitberichter: & Prof. Dr. Something\\
\end{tabular}\\[1ex]
Tag der mündlichen Prüfung: xx.xx.2019

\vspace*{2cm}

Something\\
2019 
\end{titlepage}

%-----------------------------------------------------------------------


\newpage\null\cleardoublepage
\chapter{Abstrakt}


\tableofcontents





\mainmatter

\chapter{Something1}

Somethings in chapter 1.

\chapter{Something2}

Somethings in chapter 2.

\end{document}
  • Please add a minimal code that people can test. – user156344 Apr 2 at 9:13
  • Hey Phirma, because we don't know whats in e.g. Chap1.tex we can't help you. Does the problem persist if you take out Chap1.tex? – sheß Apr 2 at 9:19
  • Thanks for the quick comments. I changed the code. The problem exists independent of Chap1.tex. It can be now tested. – Phima Apr 2 at 9:42
1

The issue bases on the redefinition of the pagestyles by the babel option farsi. If you really want to use the outdated package scrpage2, you can add

\renewcommand\chapterpagestyle{scrplain}

But I would remove package scrpage2 and load its successor scrlayer-scrpage after babel. scrlayer-scrpage redefines pagestyle plain as alias of plain.scrheadings and activates pagestyle scrheadings automatically.

Example:

\documentclass[
10pt,
%DIV=calc,% layout settings will be overwritten by geometry
parskip=half,
version=first,% Do you really want compatilbility to version 2.9? Current version is 3.26
listof=totoc,
bibliography=totoc,
index=totoc,
%cleardoublepage=empty% empty blank pages
]{scrbook}
\setuptoc{toc}{totoc}

\usepackage[includehead=false, includefoot=false, paperheight=240mm, paperwidth=170mm, 
twoside=true, left=25mm, right=20mm, top=35mm, bottom=20mm]{geometry}

\usepackage[LAE,LFE,T1]{fontenc}
\usepackage[english,greek,farsi,main=ngerman]{babel}
\usepackage{scrlayer-scrpage}% <- after babel

%\usepackage[utf8]{inputenc} not needed with an uptodate TEX distribution
\usepackage{lmodern}

\begin{document}

\frontmatter
\begin{titlepage}
\centering
\vspace*{1cm}
{\bfseries \Large Titlepage\par}
\end{titlepage}

\chapter{Abstrakt}
\tableofcontents
\listoffigures
\listoftables

\mainmatter
\chapter{Something1}
Somethings in chapter 1.
\chapter{Something2}
Somethings in chapter 2.
\end{document}

Note that I have removed the unrelated stuff. Additionally there is no need to load package tocbibind with a KOMA-Script class. It can be replaced by the class options listof=totoc, bibliography=totoc, index=totoc and by \setuptoc{toc}{totoc}.

Result:

screenshot: TOC

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.