2

As of April 2018, Windows 10 now installs some fonts through the Microsoft Store or Microsoft Office. These fonts are not installed in the usual font folder C:\Windows\Fonts, but instead in protected folders under C:\Program Files\WindowsApps. The fontspec package can't search this path, so the fonts cannot be used.

Does anyone have a work-around?

Here's a MNWE, compiled with XeLaTeX in the MikTeX package:

\documentclass{article}
\usepackage{fontspec}
\setmainfont{Georgia Pro}
\begin{document}
Hello, World!
\end{document}

The Georgia Pro font is indeed installed on my machine, as I can use it from within Windows-native apps. Older fonts, such as Georgia load without problems.

  • According to this you can install such fonts in your fonts folder: geekermag.com/windows-store-fonts-location. Beside this it is not a fontspec question but (for xelatex) of the fontconfig setting and you should better ask in the miktex issue tracker. – Ulrike Fischer Apr 2 at 14:31
1

You can add the path to your fonts to your localfonts2.conf file. This can be found in C:\ProgramData\MiKTeX\2.9\fontconfig\config and/or C:\Users\username\AppData\Roaming\MiKTeX\2.9\fontconfig\config.

  • This doesn't directly work because the folder doesn't have read permission by default. Also, each font is in a separate folder, so this is cumbersome. – Ted Corcovilos Apr 2 at 17:57
  • Follow this guide to take ownership of the WindowsApps folder. You might have to repeat it for the WindowsApps\Deleted folder. This solution works after that (on my machine at least). You don't need to add each font folder, just WindowsApps is enough. – BrtH Apr 2 at 18:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.