77

I'm using the package todonotes. How can I disable the todo notes for printing my final document? (I know it's possible, but I can't find it and I don't want to (manually) delete all my notes in the document...)

I've read the documentation, but I still have NO clue on what to type to disable todonotes. This is all I have in my preamble:

\usepackage{todonotes}
\newcommand{\td}[1]{\todo[inline]{#1}}

but commenting any of those will keep my note's text on the spot and just remove the formatting. I couldn't figure out what to type to fully remove that unless I go one by one and do it.

3
  • 2
    When you don't want your notes to be visible just change \usepackage{todonotes} to \usepackage[disable]{todonotes}
    – Splashy
    Nov 2 '10 at 14:17
  • 2
    Using the official methods is better, but you could just redefine the macro: \renewcommand{todo}[2][]{}. Oct 9 '12 at 1:13
  • how can I restore it easily, then? For me, an environment would work best to temporarily disable todo. Dec 2 at 20:49
113

I just got it: for notes not to be visible just change:

\usepackage{todonotes}

to

\usepackage[disable]{todonotes}
27

You can also give it the obeyDraft option (\usepackage[obeyDraft]{todonotes}), so that it will display todonotes if your document is in draft mode and hide them if it isn't in draft mode. However, be aware that the draft mode also only shows bounding boxes for images, so that might be an issue.

2
  • 12
    My preferred option for todonotes is obeyFinal. With this option, todonotes will be disabled only in final mode. Nov 5 '13 at 15:28
  • 3
    to have the images displayed even on draft mode, you can use \usepackage[final]{graphicx}
    – carandraug
    Jan 6 '16 at 14:30
1

An easy hack is to redefine command \todo somewhere at the top of document, e.g.

\renewcommand{\todo}[1]{}

This comes handy especially when your document is structured into multiple files, and you can not simply have control over \usepackage.

1
  • sometimes, todo has an optional argument, though :-/ Dec 2 at 20:47
1

My preferred way is \presetkeys{todonotes}{disable}{} in the preamble, which also works in case todonotes has been loaded by some previous file, and you can't easily change its \usepackage line.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.