0

Consider this script:

\documentclass{report}
\usepackage{enumerate}
\begin{document}
\begin{enumerate}[label=\arabic*)]
  \item item 1
\end{enumerate}
\end{document}

I would like the labels to be "1)" instead of "1." as per default. Therefore I use [label=\arabic*)] following p. 3 at http://mirror.datacenter.by/pub/mirrors/CTAN/macros/latex/contrib/enumitem/enumitem.pdf

However, when I compile there is an error:

! Missing number, treated as zero.
<to be read again> 
                   \c@* 
l.4 \begin{enumerate}[label=\arabic*)]

What is wrong?

  • 1
    You have to use enumitem package, not enumerate. – user156344 Apr 7 '19 at 7:57
  • @JouleV, is the same possible for enumerate? – Viesturs Apr 7 '19 at 7:59
2

enumerate and enumitem are different packages. Don't use them at the same time, and don't confuse them!

If you want to use enumerate package, the only way is

\documentclass{report}
\usepackage{enumerate}
\begin{document}
\begin{enumerate}[1)]
  \item item 1
  \item item 2
\end{enumerate}
\end{document}

enter image description here

Using enumitem is a little more complicated. However, you are using it correctly:

\documentclass{report}
\usepackage{enumitem} % NOT enumerate!
\begin{document}
\begin{enumerate}[label=\arabic*)]
  \item item 1
  \item item 2
\end{enumerate}
\end{document}

(same output as above)

or if you want to have the simple syntax of enumerate, you may need shortlabels option:

\documentclass{report}
\usepackage[shortlabels]{enumitem}
\begin{document}
\begin{enumerate}[1)]
  \item item 1
  \item item 2
\end{enumerate}
\end{document}

(same output as above)

I often use the last way listed here. You have three options, choose whatever you want.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.