0

I am trying to use EPS images in TeXstudio. I had already set everything up using PDF files, and everything works great there, but the journal I'm submitting to requires EPS. My process so far is to convert the PDFs to EPSs, and then inserting them the same way into the .tex document (dragging from the folder). They are stored in the same folder as the .tex doc.

I have played around with TeXstudio's commands, including trying XeLaTeX, changing the build & view commands, etc. I suspect I'm not getting the right combination of commands.

Sidenote: I really like TeXstudio and hope to keep using it.

What am I missing?

Edit: I have tried the following:

/usepackage{epsfig}

/usepackage{epstopdf}

And adding escape-shell to pdflatex command.

My error message is the same:

error: Package pdftex.def -- "file name" -eps-converted-to.pdf not found.

I am using TeXstudio 2.12.14 on Mac OS Mojave 10.14.

closed as off-topic by Sebastiano, Stefan Pinnow, siracusa, Mensch, marmot Jul 15 at 0:12

  • This question does not fall within the scope of TeX, LaTeX or related typesetting systems as defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    @KJO you do not need --shell-escape eps to pdf is whitelisted by default – David Carlisle Apr 9 at 18:46
  • 1
    I can confirm, that which gs works on a mac – user185220 Apr 9 at 18:57
  • 1
    what is the real name of your picture? Does it contains spaces or other curious stuff? – Ulrike Fischer Apr 9 at 19:05
  • 1
    Removing spaces from the file name worked. Thank you all for your help and patience! – Bkk Apr 9 at 23:40
  • 4
    I'm voting to close this question because the OP has finded the solution with the comments. – Sebastiano Jul 14 at 20:15