1

I am using the dialogue package in my document and I'm using scrartcl with option parskip.

How can I switch off parskip inside the dialogues? I don’t want to have that space between the lines.

\documentclass[parskip]{scrartcl}
\usepackage[utf8]{inputenc}
\usepackage{dialogue}

\begin{document}

Some text: ergk kfjnw kjeb oqie kebwueb  ueibr iwube b iueb uf bwieu beu bwob bk jbwbekjbf bwjeb bfuweij bkjejbrkjwb j.

Some more text ...

Beginn of the Dialogue
\begin{dialogue}
\speak{Tim} Hi, how are you?
\speak{Karl} I think thats obvious!
\end{dialogue}

\end{document}

How can I delete the space between TIM and KARL?

Thank you!

1

You can extend \PreDialogue to switch of option parskip inside the environment:

\documentclass[parskip]{scrartcl}
\usepackage[utf8]{inputenc}
\usepackage{dialogue}

\usepackage{xpatch}
\apptocmd{\PreDialogue}{\KOMAoption{parskip}{false}}{}{\undefined}

\begin{document}

Some text: ergk kfjnw kjeb oqie kebwueb  ueibr iwube b iueb uf bwieu beu bwob bk jbwbekjbf bwjeb bfuweij bkjejbrkjwb j.

Some more text ...

Beginn of the Dialogue
\begin{dialogue}
\speak{Tim} Hi, how are you?
\speak{Karl} I think thats obvious!
\end{dialogue}
And some text

after the dialogue.

\end{document}

result

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.