0

This question already has an answer here:

Hi i am new too latex environment. i configure the texstdio bibtex to biber. But My bibliography isn't displaying. It shows warning about empty bibliography and undefined references.

My main.tex file is

\documentclass[12pt]{report}

\usepackage{biblatex}

\addbibresource{lol.bib}

\begin{document}

 Bibliography \cite{lol}.

\printbibliography

\end{document}

My lol.bib file is

@article{lol,
author        = {B. B. CHAUDHURI* and U. PAL},
title         = {A COMPLETE PRINTED BANG¸A OCR SYSTEM},
journaltitle  = {Pattern Recognition Society},
year          = {1998},
volume        = {31},
number        = {5},
pages         = {531-549},
doi           = {10.1016/S0031-3203(97)00078-2}
}

Output is

Bibliography [lol].

error is showing.

enter image description here

i am stuck for 3 hour. what should i do??

marked as duplicate by moewe biblatex Apr 11 at 15:03

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Double-check your configuration with tex.stackexchange.com/q/154751/35864. Make sure that you are actually calling Biber (in the usual LaTeX, Biber, LaTeX, LaTeX cycle), depending on your settings you have to press an extra button for that (in the tools menu). If you are running Biber, Biber should produce log messages in the .blg file. Open that file and paste its contents here (on Windows it might be classified as a 'performance monitor file', but it is really just a text file). See also tex.stackexchange.com/q/286706/35864 – moewe Apr 11 at 12:42
  • content of .blg file paste.ubuntu.com/p/VvhR5gtfBT – Debotush Dam Apr 11 at 13:51
  • The message ERROR - Data file 'lol.bib' cannot be read in encoding 'ascii': ascii "\xC2" does not map to Unicode at is quite clear about the issue: Your file is not encoded in ASCII, but Biber expects it to be in ASCII. Does tex.stackexchange.com/q/402714/35864 help? (Also related, but with UTF-8: tex.stackexchange.com/q/459821/35864) – moewe Apr 11 at 14:06
  • Did you manage to resolve the issue? If so, may I ask how? – moewe Apr 11 at 14:22
  • yep \usepackage[backend=biber, bibencoding=utf8, style=ieee]{biblatex} "bibencoding=utf8" solved the issue thanks :) – Debotush Dam Apr 11 at 14:51

Browse other questions tagged or ask your own question.