3

I am using the cleveref package with brazilian option. I want to change the native brazilian range conjunction, as in "Figuras 1 a 3", to new brazilian range conjunction, as in "Figuras 1 à 3". How can I do it?

My MWE attempt:

\documentclass[brazil]{article}

\usepackage{babel}
\usepackage{lmodern}                        
\usepackage[T1]{fontenc}        
\usepackage[utf8]{inputenc} 

\usepackage[brazilian]{cleveref}
\crefname{figure}{Figura}{Figuras}
\makeatletter
   \def\crefrangeconjunction@preamble{ \`{a}\nobreakspace}%
\makeatother

\begin{document}

Estas são as \cref{here:one,here:two,here:three,here:four}.

\begin{figure}[!ht]
   \caption{Caption 01}
   \label{here:one}
\end{figure}

\begin{figure}[!ht]
   \caption{Caption 02}
   \label{here:two}
\end{figure}

\begin{figure}[!ht]
   \caption{Caption 03}
   \label{here:three}
\end{figure}

\begin{figure}[!ht]
   \caption{Caption 04}
   \label{here:four}
\end{figure}

\end{document}

The results from that MWE are according to this figure:

enter image description here

5

Use

\newcommand{\crefrangeconjunction}{ \`{a}\nobreakspace}

\documentclass[brazil]{article}

\usepackage{babel}
\usepackage{lmodern}                        
\usepackage[T1]{fontenc}        
\usepackage[utf8]{inputenc} 

\usepackage[brazilian]{cleveref}
\crefname{figure}{Figura}{Figuras}
%\makeatletter
%   \def\crefrangeconjunction@preamble{\"{a}\nobreakspace}%
%\makeatother

\newcommand{\crefrangeconjunction}{ \`{a}\nobreakspace}

\begin{document}

Estas são as \cref{here:one,here:two,here:three,here:four}.

\begin{figure}[!ht]
   \caption{Caption 01}
   \label{here:one}
\end{figure}

\begin{figure}[!ht]
   \caption{Caption 02}
   \label{here:two}
\end{figure}

\begin{figure}[!ht]
   \caption{Caption 03}
   \label{here:three}
\end{figure}

\begin{figure}[!ht]
   \caption{Caption 04}
   \label{here:four}
\end{figure}

\end{document}

enter image description here

  • 2
    +1. If you set the the document class option to be brazilian rather than brazil, you can omit the instruction \crefname{figure}{Figura}{Figuras}. – Mico Apr 11 at 19:52
  • @user185511, I tested your solution and it worked fine. Thank you by help. – Adriano Apr 11 at 20:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.