0

I draw a commutative diagram by following commands, but I was unable to put labels on maps (Arrows). The diagram commands are as below:

\begin{center}
\tikzcdset{row sep/normal=2cm}
\begin{tikzcd}
 & H\arrow[ddl, bend right]\arrow[ddr, bend left]\arrow[d, dashed] & \\
 & A\rtimes G \arrow[dl]\arrow[dr] & \\
 A &  & G  
\end{tikzcd}
\end{center}

The diagram appearing is as below. How to label the arrows here? What modifications in command are to be done?

enter image description here

  • ddl, bend right -> ddl, bend right, "ab", for example. – user156344 Apr 12 at 10:36
  • What problem I am facing is that, after copying your label "ab" it is producing proper output; but if I type "ab" with keys for double inverted commas, it is not running. It may be my computer problem. – Soluble Apr 12 at 10:43
  • 1
    Don't use '' but ". They are different characters – user156344 Apr 12 at 10:44
  • OK; thanks; it is working. Final question, in the two diagonal arrows, if we want to put labels them both below, how to proceed? – Soluble Apr 12 at 10:46
2

First, the labels are added in the format of quotes library, so you must use " instead of ''.

To change the style of labels, you can use option labels. This is a short example:

\documentclass{article}
\usepackage{tikz-cd}
\usepackage{amssymb}
\begin{document}
\begin{center}
\tikzcdset{row sep/normal=2cm}
\begin{tikzcd}
 & H\arrow[ddl, bend right]\arrow[ddr, bend left, "xyz"]\arrow[d, dashed] & \\
 & A\rtimes G \arrow[dl,"xyz"]\arrow[dr,"abc",labels=below left] & \\
 A &  & G  
\end{tikzcd}
\end{center}
\end{document}

enter image description here

  • Thank you very much to you and stackoverflow too. – Soluble Apr 12 at 11:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.