0

I'm having trouble using extsizes to increase the font size options for a font loaded with fontspec. My example document:

\documentclass[12pt]{article}

\usepackage{fontspec}
\setmainfont{Chaparral Pro}

\begin{document}
This text should be in Chaparral Pro.
{\bfseries This text should be in Chaparral Pro Bold.}
{\itshape This text should be in Chaparral Pro Italic.}
{\bfseries\itshape This text should be in Chaparral Pro Bold Italic.}
\end{document}

This document works as expected, with all of the text in the expected fonts. But if I change the documentclass to

\documentclass[14pt]{extarticle}

then only three of the fonts work correctly; the normal-weight text is also printed in bold. Looking at the log, it seems that fontspec is unable to load the normal weight and loads the bold weight in its place:

LaTeX Font Warning: Font shape `TU/ChaparralPro(0)/bx/n' undefined
(Font)              using `TU/ChaparralPro(0)/m/n' instead on input line 8.

Adding an UprightFont= option to setmainfont doesn't seem to help it load the right font.

Any suggestions?

EDIT (2019-04-23): I tried the same file with the Pro version of the font I have on a different machine, and the output was fine. It looks like this is an issue with this particular version of this font at this particular size, though it's not clear to me why this is a problem for fontspec, or why it doesn't report any problems.

  • 1
    You have brackets around the class name instead of braces. – Ulrike Fischer Apr 12 at 13:41
1

Either of your examples works for me; you might be using an outdated TeX distribution. Try seeing whether you have the same problem with KOMA-Script:

\documentclass[14pt]{scrartcl}

\usepackage{fontspec}
\setmainfont{Chaparral Pro}

\begin{document}
This text should be in Chaparral Pro.
{\bfseries This text should be in Chaparral Pro Bold.}
{\itshape This text should be in Chaparral Pro Italic.}
{\bfseries\itshape This text should be in Chaparral Pro Bold Italic.}
\end{document}
  • No luck with that, or with the KOMA-Script-suggested change to fontsize=14pt. – gilgamec Apr 23 at 6:59
  • There's definitely something wrong with your distribution, in that case. Or, as you say, it could be the font – I'm using version 2.081 of Chaparral Pro. – Andrew Dunning Apr 24 at 14:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.