1

I am trying to print my A5 document in the middle of A4 pages. With the answer to this question I was able to crop the pages on A4 pages. However now I am using the BCOR option of KOMAScript and this messes the cropping up completely.

For this minimum working example:

\documentclass[
a5paper,
parskip=half,
twoside,
fontsize=9.2pt,
listof=totoc,
titlepage=firstiscover
]{scrbook}

\usepackage{geometry}
% scrlayer-scrpage für angepasste Header und Footer
\usepackage[%
headsepline,
automark
]{scrlayer-scrpage}

% layouts zur Ermittlung der Textbreite in cm
\usepackage{layouts}

% Kapitelname oben auf der Nichtbindungsseite
\clearpairofpagestyles
\ohead{\textsc{\leftmark}} 
\ofoot*{\pagemark}

\usepackage[cam,a4,center]{crop}

\begin{document}
\begin{titlepage}
    \newgeometry{top=1cm,bottom=1cm,right=1cm,left=1cm}
    \centering
    \Huge Title Test
\end{titlepage}
% Der Befehl frontmatter wechselt zu römischen Seitenzahlen
\frontmatter
% Auf den Inhaltsseiten werden 15mm zusätzlicher Seitenrand auf Seite der Bindung hinzugefügt
\KOMAoptions{BCOR=15mm}

\chapter{Test}

\end{document}

The mess then looks like this:

Result of minimum working example

So on the title page the cropping is not centered. This would not be a big deal as I don't really care for the title page in the occasions where I need the cropped version.

However as soon as the \KOMAoptions{BCOR=15mm} command is used the whole A4 format is lost and the document is not printed correctly anymore.

How can I prevent this from happening without losing the functionality of cropping nor being forced to remove the BCOR command everytime I need the cropped version?

EDIT: When I use \usepackage[bindingoffset=15mm]{geometry} instead of \KOMAoptions{BCOR=15mm} the layout does not jump back to A5, but the cropped A5 page is not centered:

Result when using geometry bindingoffset

  • 1
    You are using geometry, stick to it and don't mix it with KOMA-options. Set the bindingoffset in the preamble with \usepackage[bindingoffset=15mm]{geometry} -- avoid layout changes in the document - you can easily confuse crop. – Ulrike Fischer Apr 14 '19 at 21:09
  • Hello @UlrikeFischer thanks for your comment! I added an edit where I tried the bindingoffset option of geometry instead of the KOMAoptions{BCOR=15mm}. Unfortunately this also doesn't yield the desired result. – Axel Apr 14 '19 at 21:25
  • Doesn't happen for me. How are you compiling and what is your tex system? – Ulrike Fischer Apr 14 '19 at 21:28
  • The compiling command is pdflatex.exe -synctex=1 -interaction=nonstopmode "mwe_crop".tex. I am using TeXstudio 2.12.14. – Axel Apr 14 '19 at 22:20
  • texstudio is not a tex system, it is an editor. the texsystem is miktex or texlive. – Ulrike Fischer Apr 14 '19 at 22:29
1

Here is an example on how to do something like you try to do. However it is not recommended, because usually the cover of a book has completely different dimensions than one page of a book, because the whole cover consist of the front the back and the saddle (the part you see, if the book is in your bookshelf).

\documentclass[
a4paper,
parskip=half,
twoside,
fontsize=9.2pt,
listof=totoc,
%titlepage=firstiscover,
pagesize=false,
]{scrbook}

\usepackage[a4paper,layout=a5paper,layouthoffset=31mm,layoutvoffset=43mm,bindingoffset=15mm,showcrop,
% showframe
]{geometry}
% scrlayer-scrpage für angepasste Header und Footer
\usepackage[%
headsepline,
automark
]{scrlayer-scrpage}

% layouts zur Ermittlung der Textbreite in cm
\usepackage{layouts}

% Kapitelname oben auf der Nichtbindungsseite
\clearpairofpagestyles
\ohead{\textsc{\leftmark}} 
\ofoot*{\pagemark}

%\usepackage[cam,a4,center]{crop}

\begin{document}
% Make a cover page before the document title
\begin{titlepage}
    \newgeometry{layout=a5paper,layouthoffset=31mm,layoutvoffset=43mm,top=1cm,bottom=1cm,right=1cm,left=1cm}
    \centering
    \Huge Title Test
\end{titlepage}
% Der Befehl frontmatter wechselt zu römischen Seitenzahlen
\frontmatter
\extratitle{books usually have an extra title}
\title{This is the in-book document title}
\author{Me}
\maketitle

\chapter{Test}

\end{document}

result:

cover, backside of the cover, extra title backside of the extra title, main title, backside of the main title, first chapter page

Note, the whole layout is made by geometry and completely unrelated from KOMA-Script's typearea. If you want to change this, you have to use KOMA-Script option usegeometry additionally. However in this case I would recommend to reduce the DIV value. You should not use package crop in such a scenario. So you have to do the positioning of the layout on the paper manually using geometry options.

Another approach would be to remove geometry and do the positioning of the title page by changes of the margins using KOMA-Script features, e.g., using:

\documentclass[
a5paper,
parskip=half,
twoside,
fontsize=9.2pt,
listof=totoc,
%titlepage=firstiscover,% Does not help, because it only influences \maketitle results
pagesize=false,
BCOR=15mm
]{scrbook}

% scrlayer-scrpage für angepasste Header und Footer
\usepackage[%
headsepline,
automark
]{scrlayer-scrpage}

% layouts zur Ermittlung der Textbreite in cm
\usepackage{layouts}

% Kapitelname oben auf der Nichtbindungsseite
\clearpairofpagestyles
\ohead{\textsc{\leftmark}} 
\ofoot*{\pagemark}

\usepackage[cam,a4,center]{crop}

\begin{document}
% Make a cover page before the document title
\storeareas\maintypearea
\KOMAoptions{twoside=semi,BCOR=0mm,DIV=20}
\begin{titlepage}
  \centering
  \Huge Title Test
\end{titlepage}
\clearpage\maintypearea
% Der Befehl frontmatter wechselt zu römischen Seitenzahlen
\frontmatter
\extratitle{books usually have an extra title}
\title{This is the in-book document title}
\author{Me}
\maketitle

\chapter{Test}

\end{document}

cover, cover backside, extra title extra title backside, main title, main title backside, first chapter

But still: I would not recommend this. I would recommend to build the cover as a separate document. If you need to combine the book and the cover, you can include the cover at the very beginning of the book using pdfpages.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.