4

I updated MikTex and, since then, I have an "undefined shading" error when using the Frankfurt theme. I wonder what I am doing wrong. Many thanks for your help (any fix is welcome)!

Here is a minimal working example.

\documentclass[xcolor=svgnames]{beamer}
\usetheme{Frankfurt}
\usecolortheme{crane}

\title{My title}


\author{Author}
\institute{Institute}

\date[]{Date}


\begin{document}

\begin{frame}
  \titlepage
\end{frame}


%==============================

\section{YY}
\subsection{YY1}

\begin{frame}{YY}

    \begin{itemize}
            \item XX
            \item XX

    \end{itemize}

\end{frame}

\end{document}

Compiling the file results in the following errors.

! Package pgf Error: Undefined shading "beamer@barshade".

See the pgf package documentation for explanation.
Type  H <return>  for immediate help.
 ...                                              

l.14 \begin{document}

? 

! Package pgf Error: Undefined shading "beamer@barshade".

See the pgf package documentation for explanation.
Type  H <return>  for immediate help.
 ...                                              

l.18 \end{frame}

? 
[1{C:/Users/studerm/AppData/Local/MiKTeX/2.9/pdftex/config/pdftex.map}]

! Package pgf Error: Undefined shading "beamer@aboveframetitle".

See the pgf package documentation for explanation.
Type  H <return>  for immediate help.
 ...                                              

l.34 \end{frame}

? 

! Package pgf Error: Undefined shading "beamer@belowframetitle".

See the pgf package documentation for explanation.
Type  H <return>  for immediate help.
 ...                                              

l.34 \end{frame}

? 

! Package pgf Error: Undefined shading "beamer@barshade".

See the pgf package documentation for explanation.
Type  H <return>  for immediate help.
 ...                                              

l.34 \end{frame}

1
  • Change into a different theme; then it will work Commented Mar 12, 2020 at 2:03

1 Answer 1

3

Update

with pgf 3.1.3 it should work again.

Old answer

You are doing nothing wrong. pgf changed the handling of shadings, they are no longer globally defined and this breaks a number of beamer themes.

See https://github.com/pgf-tikz/pgf/issues/650 and https://github.com/josephwright/beamer/issues/536.

3
  • Any advice on how to get it working again?
    – Olorun
    Commented May 16, 2019 at 4:07
  • @Olorun simply update. With pgf 3.1.3 it should work again. Commented May 16, 2019 at 7:14
  • @UlrikeFischer, I work with texlive2017, but I have the same error. How to resolve this error?
    – user85361
    Commented Jun 16, 2019 at 14:52

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .