1

I tried to use pkfix-helper, but I get a strange error from METAFONT. I'm MiKTeX and all packages are updated to the newest version. What does this error mean and how can I fix it?

C:\Users\username\Downloads\temp>pkfix-helper file.ps file-helper.ps
Reading file.ps ... done.
Number of Type 3 fonts encountered in included documents: 0
Total number of Type 3 fonts encountered: 22
Bitmapped fonts are typeset at 300 DPI.
Finding character widths ... done.
Reading TFM files ... This is METAFONT, Version 2.7182818 (MiKTeX 2.9.7000 64-bit)

(C:\Users\username\AppData\Local\MiKTeX\2.9\fonts/source/lh/lh-t2a\lasy12.mf
(C:\Users\username\AppData\Local\Programs\MiKTeX 2.9\fonts/source/lh/base\fikpa
rm.mf
(C:\Users\username\AppData\Local\Programs\MiKTeX 2.9\fonts/source/public/cm\cmb
ase.mf)
(C:\Users\username\AppData\Local\Programs\MiKTeX 2.9\fonts/source/lh/base\lcyrb
eg.mf)
(C:\Users\username\AppData\Local\Programs\MiKTeX 2.9\fonts/source/lh/base\lklig
tbl.mf)
>> 0.12
>> "input ecsy"
! I can't find file `ecsy'.
<scantokens> input ecsy

<to be read again>
                   ;
use_driver->...#=pt#;pt#:=true_pt#;scantokens(ss);
                                                  pt#:=true_pt#;font_identif...
l.304 use_driver(fonteq)
                        ;
Please type another input file name
! Emergency stop.
<scantokens> input ecsy

<to be read again>
                   ;
use_driver->...#=pt#;pt#:=true_pt#;scantokens(ss);
                                                  pt#:=true_pt#;font_identif...
l.304 use_driver(fonteq)
                        ;
Transcript written on lasy12.log.

Sorry, but maketfm did not succeed.

The log file hopefully contains the information to get MiKTeX going again:

  C:\Users\username\AppData\Local\MiKTeX\2.9\miktex\log\miktex-maketfm.log
This is METAFONT, Version 2.7182818 (MiKTeX 2.9.7000 64-bit)

(C:\Users\username\AppData\Local\MiKTeX\2.9\fonts/source/lh/lh-t2a\lasy17.mf
(C:\Users\username\AppData\Local\Programs\MiKTeX 2.9\fonts/source/lh/base\fikpa
rm.mf
(C:\Users\username\AppData\Local\Programs\MiKTeX 2.9\fonts/source/public/cm\cmb
ase.mf)
(C:\Users\username\AppData\Local\Programs\MiKTeX 2.9\fonts/source/lh/base\lcyrb
eg.mf)
(C:\Users\username\AppData\Local\Programs\MiKTeX 2.9\fonts/source/lh/base\lklig
tbl.mf)
>> 0.17
>> "input ecsy"
! I can't find file `ecsy'.
<scantokens> input ecsy

<to be read again>
[...]
1
  • I'm not able to find input ecsy in any file under .../fonts/source/lh/ on my TeX distribution. Nor I can find lasy12.mf in .../fonts/source/lh/lh-t2a/
    – egreg
    Apr 15 '19 at 17:28
1

Something is wrong with your METAFONT sources. Current sources of the lh cyrillic fonts identified by the labels Version 3.5 // Patchlevel= (where the Patchlevel is 0, 1, or 2 depending on the file) or 3.5g contain neither files like lasy12.mf or lasy17.mf nor the file ecsy.mf. I suggest updating your TeX distribution as a whole, or at least to upload up-todate lh cyrillic fonts.

BTW, lasy12.mf or lasy17.mf are non-standard fonts that can be build using the Sauter font building tools found in

https://ctan.org/pkg/sauterfonts

(LaTeX support for them is found in the package

https://ctan.org/pkg/sauter

). You probably need to install these packages on your computer to get the fonts lasy12.mf or lasy17.mf.

1
  • There aren't any updates available. I'll try to remove miktex completely and do a fresh reinstall.
    – someonr
    Apr 15 '19 at 18:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.