0

I try to build the examples of the limecv package after a fresh installation of MacTeX 2018 under macOS Mojave. The package requires the fonts FontAwesome and Fira which are both installed on my system according to the TeX Live Utility.

Building with XeLaTeX gives me the following error:

kpathsea: Running mktexmf FontAwesome

! I can't find file `FontAwesome'.
<*> ...our; mag:=1; nonstopmode; input FontAwesome

Please type another input file name
! Emergency stop.
<*> ...our; mag:=1; nonstopmode; input FontAwesome

Transcript written on mfput.log.
grep: FontAwesome.log: No such file or directory
mktextfm: `mf-nowin -progname=mf \mode:=ljfour; mag:=1; nonstopmode; input FontAwesome' failed to make FontAwesome.tfm.
kpathsea: Appending font creation commands to missfont.log.

/usr/local/texlive/2018/texmf-dist/tex/latex/fontawesome/fontawesome.sty:47: Pa
ckage fontspec Error: The font "FontAwesome" cannot be found.

There are several posts on tex.stackexchange, e.g., 1 2, and even a pull request that suggest to replace

\newfontfamily{\FA}{FontAwesome}

by

\newfontfamily\FA[Path=fonts/]{FontAwesome}

in fontawesome.sty to solve this issue - at least for FontAwesome. But if I do this, I get the following error:

kpathsea:make_tex: Invalid filename `[fonts/FontAwesome]/OT', contains '['

/usr/local/texlive/2018/texmf-dist/tex/latex/fontawesome/fontawesome.sty:47: Pa
ckage fontspec Error: The font "FontAwesome" cannot be found.

It seems like kpathsea adds invalid square brackets to the filename.

Is there a different syntax for macOS? Does anyone know how to fix this?

P.S. I know that I could work around this issue by installing the fonts into my system, but I would prefer to not doing so.

  • 1
    FA is several things it is a package class style font and a set of font files each has its correct place and position relative to the others TeX Live and MiKTeX have "packages" that are helper files but "currently" you need the ashwinvis forked version of cv for the class fix and the fonts from cv placed in exactly the correct location which will be a subfolder called /fonts/ "below" your /main/ folder containingcv.tex – KJO Apr 16 at 19:24
  • You might try running sudo updmap-sys in Terminal, giving your password when requested. – Herb Schulz Apr 16 at 20:33
  • Another thought.... have you updated to the final, frozen version of a TeX Live 2018. – Herb Schulz Apr 16 at 21:23
  • Thanks for the comments. @KJO: Do you mean Ashwinvis's fork of Awesome CV? Currently, I cannot see how I can use this fork to solve the mentioned problem in limecv. @Herb-Schulz: Unfortunately, sudo updmap-sys did not help. I installed all updates provided in TeX Live Utility directly after the installation of MacTeX. – JotWe Apr 16 at 21:42
  • Sorry forgot this is limecv not awesomecv, no help to your issue but I can complile LaTeX example with pdfLaTeX lualatex or xelatex running on MiKTeX with few problems am switching to TexLive for comparison – KJO Apr 16 at 23:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.