I'm new to TeX, and am struggling to format the citations and bibliography as I want them for my thesis (written in Overleaf). I have tried countless packages and different citation/bibliography styles and have searched and read relevant forum threads. Yet, I'm stuck. Apologies if this has been answered before, but I would greatly appreciate some help as this is causing me great trouble and I have to submit my thesis in less than a week. I have attached a sample .bib reference below. The full 'references' file is imported from my Mendeley library.

In-text citations should be in the format:

text requiring reference (Toledo 2009).

Bibliography should be APA style, as below, or roughly similar.

Toledo, L. F. and Haddad, C. F. B. (2009) Colors and Some Morphological Traits as Defensive Mechanisms in Anurans. International Journal of Zoology 2, 1-12.

So far, I have had greatest success without specifying any packages in the preamble, and only using..:


...in the end of my document.

However, it is not quite right, because in-text citations have square brackets and separate author from year with a comma. The bibliography looks all right, it only needs to not repeat the square-bracketed citation (as it appears in-text) at the beginning...

Please take pity and help.

    title = {{Colors and Some Morphological Traits as Defensive Mechanisms in Anurans}},
    year = {2009},
    journal = {International Journal of Zoology},
    author = {Toledo, Luís Felipe and Haddad, Célio F. B.},
    pages = {1--12},
    volume = {2},
    isbn = {1687-8477{\textbackslash}r1687-8485},
    doi = {10.1155/2009/910892},
    issn = {1687-8477},
    pmid = {17969693}
  • Welcome to TeX.SE.
    – Mico
    Commented Apr 22, 2019 at 1:11

2 Answers 2


So for APA writing, you can use the apa6 Latex class that can help format things into APA as far as the paper styling and citations are concerned. (http://ctan.sharelatex.com/tex-archive/macros/latex/contrib/apa6/apa6.pdf)

However, if you are writing a thesis, you can use the following

\usepackage{natbib} #Loads cite commands

\bibliographystyle{apa} #Tells Latex your bibliography style
\bibliography{BIBFILE} #Replace BIBFILE with the name of your bibliography file

Generally, I like to have my references in a .bib format and import them into my documents as I did above rather than merging them in the same document.

To cite things in text, you can use \cite{citekey} for Author (YEAR) output, and \citep{citekey} for (Author, YEAR).

Latex should format the authors based on the APA manual. If not, there is the apacite package, but I am not too sure how that works on a standard article class document or report class for this matter.

I hope this helps!

  • 1
    The bibliography style called apa was last updated in 1992 -- and thus does not implement current APA formatting guidelines for bibliographies. To adhere to current APA formatting guidelines, you should recommend in your answer that the OP employ the apacite bibliography style and load the apacite package. It is not necessary to load the apa6 document class just to use the apacite bibliography style and citation management package.
    – Mico
    Commented Apr 22, 2019 at 0:49
  • @Jennifer Thank you!!! This works for me.
    – Tara
    Commented Apr 22, 2019 at 8:38
  • @Mico Thanks for your comment. I tried this as well. Using package=apacite, \cite and bibliographystyle=apacite seemed to produce the same formats as package=natbib, \citep and bibliogrpahystyle=apa, the only difference being that apacite also prints doi and the web page the reference was downloaded from. There is probably a way to exclude unwanted elements of a reference entry (non-manually), I tried following your suggestion below, but my pdf wouldn't compile, I think this was the culprit: File `xurl.sty' not found
    – Tara
    Commented Apr 22, 2019 at 8:40
  • @Tara - The xurl package is of fairly recent vintage. If you haven't updated your TeX distribution in the last 12 months or so, the package won't be availalble. In that case, do load the url package, preferably with the options spaces and hyphens. Or, do consider bringing your TeX distribution up to date.
    – Mico
    Commented Apr 22, 2019 at 8:42
  • Now, all I need to do is disable the (green..) hyperlinks in my pdf. I have tried: \usepackage[colorlinks=false]{hyperref} and \usepackage[colorlinks=true,allcolors=black]{hyperref} and \usepackage[colorlinks=true,linkcolor=black]{hyperref} without success: "Option clash for package hyperref". Seems counterintuitive to load a new package called hyperref, when hyperrefs is what I'm trying to get rid of... Any better ideas? Sorry for being a noob.
    – Tara
    Commented Apr 22, 2019 at 8:57

If you're supposed to be formatting the bibliographic entries according to (current) APA guidelines, you should looking into using the apacite bibliography style and the apacite citation management package.

The apalike bibliography style was last updated meaningfully in 1988 and thus doesn't come close to implementing current APA guidelines.

enter image description here

Note the use of & rather than and as the conjunction between the author names in a two-author piece, in both the parenthesis-style citation call-out and the formatted bibliographic item.

    title = {Colors and Some Morphological Traits as Defensive Mechanisms in Anurans},
    year   = {2009},
    journal= {International Journal of Zoology},
    author = {Toledo, Luís Felipe and Haddad, Célio F. B.},
    pages  = {1--12},
    volume = {2009},
    isbn   = {1687-8477{\textbackslash}r1687-8485},
    doi    = {10.1155/2009/910892},
    issn   = {1687-8477},
    pmid   = {17969693}


\cite{Toledo2009} % or "\citeA{...}" for "textual-style" citation call-out

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .