I'm writing my thesis as a report document using TeXShop (pdflatex and bibtex) and want the bibliography to get its own section number and appear in the table of contents. Here's what I've tried so far and the problems arising:


Does not add the section number, not in the toc and naturally not in the section title.


Error: ! Incomplete \iffalse; all text was ignored after line 1.


The only problem this leaves is that this starts the actual bibliography on the next page after it inserts 2.5 References. Otherwise I would be happy with this solution. How can I solve this issue?


Preliminary remark: In the report class, the bibliography will by default be typeset as an unnumbered chapter. If I understand correctly, you do not only want the bibliography to be numbered, but also "downgraded" to a section.

One solution is to selectively change the definition of \thebibliography. Add the following to your preamble:


In the main document body, just use


I left out \cleardoublepage for the sake of consistency (sections do not automatically start a new page).

  • Works like a charm, thank you very much! (And also for correcting the bibilography-typo) :) – Pascal Nov 3 '10 at 18:17
  • 1
    Note that this doesn't work with natbib. I've changed natbib.sty (added an option tocnumber) to get me a numbered \section – Pascal Jan 6 '11 at 11:40
  • 2
    @Pascal: it's not necessary to change natbib; all that's needed is to \renewcommand{\bibsection}{\chapter{\refname}} or \renewcommand{\bibsection}{\section{\bibname}}, depending on the level you want assign the bibliography to. – egreg Jun 11 '11 at 10:10
  • @egreg You're absolutely right, thanks for this! – Pascal Jun 12 '11 at 16:18
  • This does not work on a Report document class does it – wolfsatthedoor Jul 25 '18 at 21:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.