1

I would like to revisit an old question, namely how to compile pstricks code properly. I tried to use the dvi-ps-pdf chain with the latex compiler within texstudio but it failed because ps2pdf seems to get stuck. I am using the latest version of MacOS (Mojave) as well as TeXStudio with TeXLive.

I also tried to compile with XeLaTeX and to use shell escape with pdflatex but both didn't work either.

I would be grateful for any suggestions!

  • Do you have Ghostscript installed? – Herb Schulz Apr 27 at 20:36
  • 2
    "seems to get stuck" doesn't give enough information for anyone to help. What error did you get? – David Carlisle Apr 27 at 20:37
  • @DavidCarlisle I am not receiving a particular error, rather nothing happens at all. The system keeps running for a long time and I terminated the compiling after a few minutes. – Hazards Apr 27 at 20:45
  • @HerbSchulz No, actually not. Should I install it? – Hazards Apr 27 at 20:45
  • which loops ps2pdf or latex? ps2pdf is just a wrapper around ghostscript it shouldn't hang if you don't have gs installed., You could post a small complete document and then we can check if there are any postscript errors. You could write a postscript loop in pstricks that would hang a postscript interpreter , so it could be a postscript error in your pstricks input.... – David Carlisle Apr 27 at 20:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.