1

I discovered the bstctlcite option which IEEE includes as part of the IEEEtran class. Specifically, I am using the ctlmax_names_forced_etal option to shorten a long list of author names. My document was written for a conference, so I was using ieeeconf.cls, not IEEEtran.cls. I had to add the following to my preamble (note, taken from here, because the example in the IEEEtrans documentation gave me an error "Use of \bstctlcite doesn't match its definition.

\bstctlcite{"): 
\makeatletter
\def\bstctlcite{\@ifnextchar[{\@bstctlcite}{\@bstctlcite[@auxout]}}
\def\@bstctlcite[#1]#2{\@bsphack
  \@for\@citeb:=#2\do{%
    \edef\@citeb{\expandafter\@firstofone\@citeb}%
    \if@filesw\immediate\write\csname #1\endcsname{\string\citation{\@citeb}}\fi}%
  \@esphack}
\makeatother 

Reducing the number of names worked excellently, but it also introduced a tilde (~) in the author names i.e. A.~Nother et al. How do I get rid of the tilde?

This question is very similar to How to remove an unwanted tilde in the citations? especially the title, but it has a different answer, so I don't think it is a duplicate.

1

The answer was in the other options set as part of the bstctlcite. I had taken the "default options" from the IEEEtrans documentation:

@IEEEtranBSTCTL{IEEEexample:BSTcontrol,
CTLuse_article_number = "yes",
CTLuse_paper = "yes",
CTLuse_forced_etal = "no",
CTLmax_names_forced_etal = "10",
CTLnames_show_etal = "1",
CTLuse_alt_spacing = "yes",
CTLalt_stretch_factor = "4",
CTLdash_repeated_names = "yes",
CTLname_format_string = "{f.˜}{vv˜}{ll}{, jj}",
CTLname_latex_cmd = ""
CTLname_url_prefix = "[Online]. Available:"
}

and modified CTLuse_forced_etal = "yes" and CTLmax_names_forced_etal = "3". The tilde comes from the CTLname_format_string, which I modified to become: CTLname_format_string = "{f. }{vv }{ll}{, jj}"

There is a risk that somebody's initial and name will be split over multiple lines, but since I am restricting to just 3 names, they will usually all fit on one line.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.