1

I wish to provide a setup script to my colleagues which sets up a working MiKTeX environment. Installation is done in 'basic' mode without admin privileges -- so far using the registry:

miktexsetup --local-package-repository=\\mymirror\miktex --package-set=basic install --modify-path --shared=no --verbose --use-registry
mpm --verbose --repository=\\mymirror\miktex --update
initexmf --enable-installer --updatefndb

Works, but the first call to pdflatex opens the "Package Installation" dialogue, asking me where to install from (I thought I already defined that with --local-package-repository) for whom (despite --shared=no) and if it should ask me again for the next package (despite --enable-installer).

How can I disable this annoying dialogue? If my colleagues are given any chance to goof it, somebody will.

2

You can change the configuration value [MPM]AutoInstall (documented here):

initexmf --set-config-value=[MPM]AutoInstall=t

Or, if you want to disable the auto-installer:

initexmf --set-config-value=[MPM]AutoInstall=f

To get back the annoying dialog:

initexmf --set-config-value=[MPM]AutoInstall=?
  • Works for me, but is weird. According to the initexmf documentation, initexmf --enable-installer should do the same and "overrules settings in the MiKTeX configuration data store". – Twonky May 10 at 8:46
  • --enable-installer does not modify the MiKTeX configuration data store. It just enables auto-installation for the current program invocation. – Christian Schenk May 11 at 10:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.