10

I am using LaTeXiT (pierre chachatelier, www.chachatelier.fr) - latex equation editor for Powerpoint for mac.

It's producing pdf that appear to be "cropped" on top (see attached) - I've tried already with changing the "margins" option (Preferences>General) but unsuccessfully - don't think that's the problem.

Any hint?

Thanks

latexit cropped pdf

  • 1
    I tried your exact text and it worked fine for me. Weird indeed. FWIW, I'm running it on Mac OS 10.13.6. – LarrySnyder610 May 3 at 13:15
  • Happens for me too for any graphical export format. (I am using Ghostscript 9.27.) – jvriesem Sep 5 at 16:37
  • Thought I had a fix by going to LaTeXiT --> Preferences --> Typesetting, and change the Ghostscript (gs) path to /usr/local/bin/ps2pdf. Turns out it ALMOST works. Still some cropping going on. – commonhare Sep 22 at 18:58
15

I assume you are using Ghostscript 9.27 which turns out to have a bug creating bounding boxes. There is patch and an updated Ghostscript 9.27 installer package is available in the systems/mac/mactex section of a CTAN repository near you. (NOTE: at the time this note was written it may not have been fully distributed so make sure the date of the file is 20190502.) The updated installer is also available at <https://www.tug.org/mactex/morepackages.html>.

  • I'm using ghostcript from homebrew so I had to reinstall ghostcript 9.26. Do you know if the bug has been fixed in the ghostscript source and we can anticipate seeing the fix in a new version? – vancleve Jun 28 at 20:19
  • 1
    @vancleve : I have no connection to Ghostscript development so can’t answer your query. – Herb Schulz Jun 29 at 13:51
  • When I upgraded via homebrew from gs 2.7 to 2.7.1 the problem was fixed. – Tom Verhoeff Jul 31 at 11:42
  • Can confirm that reinstalling Ghostcript 9.27 via the above link fixed the problem for me, running Ghostscript 9.27, LaTeXit 2.13.2 and MacTeX 2019 on MacOSX Mojave. (Wish I'd tried this sooner! Thanks HS!) – jvriesem Oct 19 at 16:12
  • The patch on CTAN fixed this for me. – John Oct 26 at 19:02
0

In addition to Herb Schulz's answer you may also have to change the Ghostscript path to use the new version. To do this go to Preferences, Typesetting and change the path for "Ghostscript (gs)" to the newest Ghostscript executable/alias in "/usr/local/bin". For me I had to change it from "/usr/local/bin/gs-noX11" to "/usr/local/bin/gs".

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.