I have an EPS file generated by gnuplot. I used the code:

#set term post enh color
#set out '1.eps'

The EPS file viewer in gsview is horizontal. However, when I include it in my paper the graph is rotated 90 degrees (vertical)

I tried set term post enh color port, it doesn't work.

However, I found the following code can be used with LaTeX:

#set term post enh color eps
#set out '1.ps'

then use gsview to convert the PS file to EPS. It will be displayed horizontally in LaTeX (but rotated 90 degrees in gsview)

How can I get the EPS file such that it is rotated 90 degrees in both?

  • 1
    Welcome to TeX.sx! This question has very little to to with TeX, and in its current form is likely to be closed. Please include a minimal working example to show us how you are including graphics, so we can make sure that it's a problem with gnu plot rather than your LaTeX code.
    – qubyte
    Commented Mar 22, 2012 at 6:30

2 Answers 2


Your first line set term post enh color says you want a PS file, while the second line, set out '1.eps' - that you want an EPS file. Gnuplot uses different aspect ratios for PS and EPS output.

Use this:

set term post enh color eps
set ou "1.eps"

Here is the result of this Gnuplot file

set term post enh color eps
set ou "1.eps"
plot x
set ou

and TeX file


EPS file:

enter image description here

DVI file:

enter image description here


Using set terminal postscript portrait on Gnuplot, as you have said, rotates 90 degrees. There are three orientation related options in postscript terminal: landscape, portrait, and eps. Usually, eps option gets orientation right for both LaTeX and gv. If gv rotates the figure in 90 degrees, then configuration for gv should be changed, the orientation settings to Automatic.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .