1

I followed the advice at tlmgr: Remote repository is newer than local (2017 < 2018) and upgraded my TeX installation following the tutorial at https://www.tug.org/texlive/upgrade.html.

When I ran the update-tlmgr-latest.sh script, using

sh update-tlmgr-latest.sh

I obtained:

sh update-tlmgr-latest.sh 
Verifying archive integrity... All good.
Uncompressing TeX Live Manager Updater  100%  
./runme.sh: updating in /usr/local/texlive/2019...
./runme.sh: tlmgr version says this is TeX Live 2018,
./runme.sh: and this updater script created: Thu Feb  7 02:56:31 CET 2019.
./runme.sh: proceeding with tlmgr update.
./runme.sh: updating /usr/local/texlive/2019/bin/x86_64-linux ...
./runme.sh: /usr/local/texlive/2019/bin/x86_64-linux/tlmgr including objects: master/tlpkg/tlpobj/texlive.infra.tlpobj master/tlpkg/tlpobj/texlive.infra.x86_64-linux.tlpobj
D:tlmgr:main: ::tldownload_server defined: TeXLive::TLDownload=HASH(0x5631e5578850)
D:setup_programs: preferring system versions
D:trying to set up system curl, arg --version
D:program curl found in the path
D:trying to set up system wget, arg --version
D:program wget found in the path
D:trying to set up system lz4, arg --version
D:program lz4 not usable from path
D:(unix) trying to set up lz4, default /usr/local/texlive/2019/tlpkg/installer/lz4/lz4.x86_64-linux, arg --version
D:Using shipped /usr/local/texlive/2019/tlpkg/installer/lz4/lz4.x86_64-linux for lz4 (tested).
D:trying to set up system gzip, arg --version
D:program gzip found in the path
D:trying to set up system xz, arg --version
D:program xz found in the path
DD:dumping $::progs = {
  'compressor' => 'lz4',
  'curl' => 'curl',
  'gzip' => 'gzip',
  'lz4' => '/usr/local/texlive/2019/tlpkg/installer/lz4/lz4.x86_64-linux',
  'tar' => 'tar',
  'wget' => 'wget',
  'working_compressors' => [
    'lz4',
    'gzip',
    'xz'
  ],
  'working_downloaders' => [
    'curl',
    'wget'
  ],
  'xz' => 'xz'
};
./runme.sh: done.

The "done" lead me to think that the upgrade went smoothly, but I'm afraid it did not.

tlmgr update --self --all returns

tlmgr: Remote repository is newer than local (2018 < 2019)
Cross release updates are only supported with
  update-tlmgr-latest(.sh/.exe) --update
Please see https://tug.org/texlive/upgrade.html for details.

and tex -v starts by TeX 3.14159265 (TeX Live 2018).

What's wrong?

  • And, BTW, isn't the message returned by tlmgr update --self --all wrong? If I try sh update-tlmgr-latest.sh --update, I get Unrecognized flag : --update. – Clément May 6 at 15:42
  • you need to change your PATH you have 2018 and 2019 installed and your PATH is still pointing at 2018 – David Carlisle May 6 at 15:49
  • that is what do which tex and which tlmgr report? – David Carlisle May 6 at 15:51
  • They both point to the correct location (i.e., /usr/local/texlive/2019/bin/x86_64-linux/), both as root and as normal user. – Clément May 6 at 15:51
  • well that's weird... sorry no other ideas. where did you change the path though, the default install does not do that – David Carlisle May 6 at 15:53
1

I'm not sure how I solved my issue, but I did:

  1. Delete update-tlmgr-latest.sh
  2. Re-download update-tlmgr-latest.sh from http://mirror.ctan.org/systems/texlive/tlnet/update-tlmgr-latest.sh
  3. Run the script again, from the /usr/local/texlive/2019/bin/x86_64-linux/ folder, using (as root) sh update-tlmgr-latest.sh.
  4. Had the same output as the one posted in the question.
  5. Ran (still as root, still in the same folder) tlmgr update --self --all.

And this time it worked:

> tlmgr update --self --all 
tlmgr: package repository http://ctan.math.washington.edu/tex-archive/systems/texlive/tlnet (verified)
tlmgr: saving backups to /usr/local/texlive/2019/tlpkg/backups
[  1/489] auto-remove: psu-thesis ... done
[  2/489] auto-remove: mbenotes ... done

etc.

I have no idea why it worked this time, my PATH variables were correctly set in

  • /etc/login.defs
  • / etc/environment
  • /etc/profile
  • ~/.bashrc

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.