5

Yesterday I installed TeXLive 2019 on my Mac using MacTeX 2019. I am working quite a lot with asymptote, so I was surprised, that asy seemed to have stopped working. No error message, but also no resulting png (I like pngs).

Today I found out that for any .asy the command asy -f png myFile.asy perfectly produces a png in a quite bad resolution, as does asy -f png -render 0 myFile.asy (well, 0 is the default). But any value larger than 0 results in no png being created.

My preferred setting would be 4 or even 5. Can somebody confirm, that for now it stopped working? What did change in asymptote (or the converter used to get from .eps to .png) that made it stop working and how can I get that back?

Edit: To also provide an example, let's just draw two arrows

import settings;
import three;
size(7cm);
DefaultHead.size=new real(pen p=currentpen) {return 1.8mm;};
currentprojection=perspective( camera = (0.0, 0.0, 4.0), up=Y, target = (0.0, 0.0, 0.0) );

draw( (0.0, 0.0, 0.0)--(0.7071, 0.7071, 0.0), rgb(0.565, 0.128,0.550), Arrow3);
draw( (1.0, 0.0, 0.0)--(1.6, 0.7071, 0.0), rgb(0.128,0.565,0.550), Arrow3);

Then

  • asy example.asy produces a nice eps
  • asy -f png example.asy produces a quite low res png (since 2019 with transparent background)
  • asy -f png -render 1 example.asy does not give an error, but neither produces a file, the same for setting render to 2,3,4 or 5.
  • as marmot suggested I also tried putting settings.render=4; into the file, which has the same effect as the last try with -render (so at least its consistently broken).
12
  • Could you perhaps add an explicit example?
    – user121799
    May 7 '19 at 5:07
  • I reproduce the effect also when I add settings.render=4; to the asy file.
    – user121799
    May 7 '19 at 5:18
  • I extended my Question and added an example and the variations I tried as well as your suggestion.
    – Ronny
    May 7 '19 at 6:23
  • 1
    Imagemagick convert, available for all platforms, which has tons of options (also for transparency etc.).
    – Marijn
    May 7 '19 at 8:55
  • 1
    So for now, one can just use the TeX Live Utility delivered with MacTeX and switch back to 2018, then asy works again.
    – Ronny
    May 7 '19 at 13:26
1

The error posten in the original question was a bug with MacTeX (TexLive) 2019. With MacTeX 2020, this is fixed. To get the rendering option back and work correctly, update to MacTeX 2020; tested with Mac OS Catalina.

4
  • This does not provide an answer to the question. To critique or request clarification from an author, leave a comment below their post. - From Review
    – Sebastiano
    Apr 17 '20 at 9:45
  • hm, well basically the question posted above by myself is fixed by updating to MacTeX 2020, what more should be given here? I am the original author, and this is the answer that solves the question.
    – Ronny
    Apr 17 '20 at 10:12
  • Excuse me very much. :-( I'm sorry I have not seen that the author was yourself. +1
    – Sebastiano
    Apr 17 '20 at 10:15
  • 1
    Nevermind :) I took your comment to extend the answer at least.
    – Ronny
    Apr 17 '20 at 10:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.