4

I want to cite a reprint of a paper with biblatex / biber and the IEEE citation style. The fast solution to use the note field results in the added text "in between the reference" and not at the end as I want it for the IEEE style.

What I want to achieve

J. Doe, “A very important paper,” in Conference on Important Publications, 2000, pp. 1–42. Reprinted in J. Miller, "Collection of Important Papers," in Book Title, 2012, pp. 100-142.

Hence, I am looking for an easy way to add the reprint information, as the note field approach yields

J. Doe, “A very important paper,” in Conference on Important Publications, Reprinted in Miller: Collection of Important Papers, Book Title, 2019, pp. 100-142, 2000, pp. 1–42.

Please have a look at the following minimal not working example

\RequirePackage{filecontents}
\begin{filecontents*}{mybib.bib}
@InProceedings{Author2000,
  author     = {Jon Doe},
  title      = {A Very Important Paper},
  booktitle  = {Conference on Important Publications},
  year       = {2000},
  pages      = {1--42},
  note       = {Reprinted in Miller: Collection of Important Papers, Book Title, 2019, pp. 100-142},
}
\end{filecontents*}


\documentclass{scrreprt}
\usepackage[utf8]{inputenc}
\usepackage{filecontents}
\usepackage[
    backend=biber,
    style=ieee,
    dateabbrev=false,
]{biblatex}
\addbibresource{mybib.bib}


\begin{document}
\cite{Author2000}
\printbibliography%
\end{document}
6

The way to do this is to use a related entry.

Create your inbook entry as normal in your bib file.

Then add a related field referring to your inbook entry and a relatedstring with the the string you want to introduce the related entry with. Some are defined as localisation string, but "Reprinted in" isn't, so you'll have to specify it in full.

You'll also want to redefine \begrelateddelim to put a period between the main entry and the related entry in your bibliography.

MWE

\RequirePackage{filecontents}
\begin{filecontents*}{\jobname.bib}
@InProceedings{Author2000,
  author        = {Jon Doe},
  title         = {A Very Important Paper},
  booktitle     = {Conference on Important Publications},
  date          = {2000},
  pages         = {1--42},
  related       = {Author2012},
  relatedstring = {Reprinted in}
}
@InBook{Author2012,
  author    = {J. Miller},
  title     = {Collection of Important Papers},
  booktitle = {Book Title},
  date      = {2012},
  pages     = {100-142}
}
\end{filecontents*}
\documentclass{article}
\usepackage[style=ieee,dateabbrev=false]{biblatex}
\addbibresource{\jobname.bib}
\renewcommand*{\begrelateddelim}{\addperiod\space}
\begin{document}
\cite{Author2000}
\printbibliography
\end{document}

output

3
  • Perfect, this is exactly what I searched for. With my biblatex version v3.10 I do not have the option \begrelateddelim, hence I ignored that part. What is indeed very strange is, that if I add a second source with a reprint, only the first gets the reprint information listed, in the second it is ignored. Do you know a reason for that? – Roos May 7 '19 at 14:44
  • @Roos Can you ask a new question with an example about the ignored related entry, please? Intuitively, I'd have said this should not be happening, but it is hard to tell what exactly goes wrong without seeing an example. – moewe May 8 '19 at 5:31
  • @moewe: I accepted the answer as it was the solution to my problem / question. For the ignored second reprint entry I opened a new question as you wished: tex.stackexchange.com/questions/489724 – Roos May 8 '19 at 6:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.