0

This question already has an answer here:

As the picture shows, at the top there is too much spacing:

I think it has to do with the following code, I already tried to change all the numbers given (.5ex etc.) but it is just the space in between Chapter I and Introduction.

Here is the preamble and part of the code I am using which I assume should be responsible for the problem:

%%%%Definition Partitioning%%%%
%Profondeur de la numérotation:
%Chapitre:
\renewcommand{\thechapter}{\Roman{chapter}}
\titleformat{\chapter}[display]
{\bfseries\Large\color{MyBlueChapter}}
{\filright\MakeUppercase{\chaptertitlename} \huge{\color{MyBlueChapter}\thechapter}}
{.5ex}
{%\titlerule
\vspace{.5ex}%
\filright}
[\vspace{1.5ex}%
\titlerule]


\usepackage[english]{babel}
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage[left=2cm,right=2cm,top=3cm,bottom=3cm]{geometry}
\usepackage{lmodern}
\usepackage{graphicx}
\usepackage{microtype}
\usepackage{geometry}
\newcommand{\latin}[1]{\textit{#1}}
\usepackage{hyperref}
\usepackage{wrapfig}
\usepackage{color}
\usepackage{lscape}
\usepackage{pdfpages}
\usepackage{fancyhdr}
\usepackage{lastpage}
\usepackage{titlesec}
%\usepackage{xcolor}
\usepackage{sectsty}
\usepackage{multicol}
\usepackage{titlesec}
\usepackage[]{nomencl}
\usepackage{gensymb}
\usepackage{amsmath}
\usepackage{cancel}
\usepackage{booktabs}
\usepackage{subfigure}
\usepackage{multirow}
\usepackage{rotating}
\usepackage[thinlines]{easytable}
\usepackage{adjustbox}
\usepackage{titletoc}
\usepackage{afterpage}
\usepackage{changepage}
\usepackage{makecell}
\usepackage{float}

Thanks for the help!

marked as duplicate by schtandard, Stefan Pinnow, Phelype Oleinik, siracusa, Andrew Swann Jun 7 at 11:28

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 5
    Please provide a full minimal example instead of just a very long preamble. – daleif May 7 at 14:04
  • Try using the [showframe] option of geometry (which is loaded twice, BTW). You might try removing every package one at a time and see if it makes any difference. If the document doesn't change, leave it off. – John Kormylo May 7 at 15:03
0

There are not too much space. There are space needed to elegantly highlight the chapter title without use another more questionable resources as use a enormous awful font, backgrounds, rules and so on.

So the best the best solution is left that space as is.

Said that, is you insist on removing that space:

(a) the code of your posted is of little help. It cannot be compiled, there are a lot of irrelevant packages and worse the document class is unknown. It matter if the document class is book, memoir os any other.

(b) Probably your question is a duplicate of How to decrease spacing before chapter title?.

(b) Probably you can redefine \@makeschapterhead as explained in the linked question, or simply use the dirty trick of add some negative space in the chapter format, for instance some like...

\titleformat{\chapter}[display]{\vspace{-50pt}\bfseries ...

Again, assuming that you are is a document class like book or report, because that will not work if you switch to memoir, for instance.

Not the answer you're looking for? Browse other questions tagged or ask your own question.