0

I hope someone has the kindness and endurance to help me out with installing uarial in TeX Live, I would be really grateful for that. I have tried so much for a few days now and for me it is quite complicated because I am not used to this stuff - but unfortunately I have to specifically use Arial in my thesis, so here I am.

I have downloaded uarial from getnonfreefonts and have run in cmd.exe texlua install-getnonfreefonts (as administrator). I get this, which looks fine to me?:

C:\Users\~\Desktop> texlua install-getnonfreefonts Detected System: win32 Detected Installation: C:/texlive/2019 Installing texmf-dist/scripts/getnonfreefonts/getnonfreefonts.pl ... [done] Installing texmf-dist/doc/man/man1/getnonfreefonts.1 ...
[done] Installing texmf-dist/doc/man/man1/getnonfreefonts.man1.pdf ... [done] md5sum: a9e772165e8fdb620bcf9c75c17facda getnonfreefonts.pl ... [ok] md5sum: 49be4444054d85b6037d237552a7cea1 getnonfreefonts.1 ...
[ok] md5sum: f825d523d686dbecdc787535b40f09d0 getnonfreefonts.man1.pdf ... [ok] Creating wrapper in 'bin/win32' ...
1 Datei(en) kopiert. [done] mktexlsr: Updating C:/texlive/2019/texmf-dist/ls-R... mktexlsr: Updated C:/texlive/2019/texmf-dist/ls-R. mktexlsr: Done.

After this I used getnonfreefonts --sys -all, and I end up with this:

C:\Users\~\Desktop>getnonfreefonts --sys -all --2019-05-07 22:22:03-- https://www.tug.org/~kotucha/getnonfreefonts/getfont.p

Resolving www.tug.org... 91.121.174.77 Connecting to www.tug.org|91.121.174.77|:443... connected. HTTP request sent, awaiting response... 200 OK Length: 33001 (32K) Saving to: 'getfont.pl'

getfont.pl 100%[===================>] 32,23K --.-KB/s in 0,03s

2019-05-07 22:22:03 (1,04 MB/s) - 'getfont.pl' saved [33001/33001]

---------------------------------------------- Installation directory: C:/texlive/texmf-local ---------------------------------------------- arial-urw Arial (URW) [installed] classico
Classico (URW) [installed] dayroman Day Roman (Apostrophiclabs)
[installed] gandhi Gandhi (Librerias Gandhi S.A. de C.V.)
[installed] garamond GaramondNo8 (URW)
[installed] garamondx GaramondNo8 Expert (URW & Michael Sharpe)
[installed] lettergothic LetterGothic (URW)
[installed] literaturnaya Literatunaya (Paragraph)
[installed] luximono Luxi Mono (Bigelow & Holmes)
[installed] vntex-nonfree VnTeX nonfree (URW & Han The Thanh)
[installed] webomints Webomints (Galapagos Design Group)
[installed]

To be sure I ran getnonfreefonts --sys --refreshmap, too:

C:\Users\~\Desktop>getnonfreefonts --sys --refreshmap --2019-05-07 22:27:05-- https://www.tug.org/~kotucha/getnonfreefonts/getfont.p

Resolving www.tug.org... 91.121.174.77 Connecting to www.tug.org|91.121.174.77|:443... connected. HTTP request sent, awaiting response... 200 OK Length: 33001 (32K) Saving to: 'getfont.pl'

getfont.pl 100%[===================>] 32,23K --.-KB/s in 0,02s

2019-05-07 22:27:06 (1,41 MB/s) - 'getfont.pl' saved [33001/33001]

---------------------------------------------- Installation directory: C:/texlive/texmf-local ---------------------------------------------- Installing 'ua1.map'... [done] Installing 'classico.map'...
[done] Installing 'dayroman.map'...
[done] Installing 'gandhi.map'...
[done] Installing 'ugm.map'...
[done] Installing 'zgm.map'...
[done] Installing 'ulg.map'...
[done] Installing 'tli.map'...
[done] Installing 'ul9.map'...
[done] Installing 'garamondvn.map'...
[done] Installing 'classicovn.map'...
[done] Installing 'webo.map'...
[done]

Running 'mktexlsr C:/texlive/texmf-local >NUL 2>NUL' ...
[done]

Updating map files (updmap-sys). Be patient...
[done]

When I checked in C:\texlive\2019\texmf-config\web2c the updmap.cfg file I found this:

Map ua1.map Map classico.map Map dayroman.map Map gandhi.map Map ugm.map Map zgm.map Map ulg.map Map tli.map Map ul9.map Map garamondvn.map Map classicovn.map Map webo.map

After this I went to Texmaker and included:

\usepackage[scaled]{uarial} \usepackage[T1]{fontenc}
\renewcommand*\familydefault{\sfdefault}

and I get this :(

LaTeX Font Warning: Some font shapes were not available, defaults substituted. LaTeX Font Warning: Font shape OMS/ua1/m/n' undefined LaTeX Font Warning: Font shapeT1/ua1/m/sc' undefined

The produced pdf is written in Helvetica or some other kind, at least it is not Arial...

When I just include

\usepackage[scaled]{uarial} \usepackage[T1]{fontenc}

there is no error message, but the font isn't changed to Arial either.

Can someone please help me? Thank you SO much in advance! Best regards.

  • 2
    uarial is a curious mix between helvetica and arial: tex.stackexchange.com/a/309120/2388. Beside this the font substituation messages looks harmless. – Ulrike Fischer May 7 at 20:56
  • 1
    OMS/ua1/m/n would be for math symbols. T1/ua1/m/sc would be upright small caps. – Davislor May 7 at 21:01
  • 1
    New Arial (win10) NOT= Old Arial (XP) = an older MSwin font ~= modified Helvetica ~= Uarial therefore Uarial NOT= Arial So what do you realy need? Nearest for pdfLaTeX may be modified winfont loading Arial from Win8.1 (?Old/New Arial?) otherwise easy route use XeLaTeX – KJO May 7 at 21:41
  • @Ulrike Fischer Thanks for pointing out that uarial is not the exact same thing as Arial and the link! – TeXlearner May 8 at 12:56
  • Thanks everyone! This helped me a lot! – TeXlearner May 8 at 12:56
2

What you posted should work. URW Arial is not exactly the same as the version from Monotype that Microsoft distributes.

The messages you got are mostly harmless. OMS/ua1/m/n is a math symbol alphabet. T1/ua1/m/sc is small caps.

If you’re allowed to use LuaLaTeX or XeLaTeX, and you want to use Microsoft Arial, the best approach is:

\usepackage{fontspec}
\defaultfontfeatures{Scale = MatchLowercase}
\setmainfont{Arial}[Scale = 1.0]

If you want to use Arial in math mode as well, see here.

In PDFLaTeX, you can also use winfonts. (As of 2018, this was broken on systems that have a newer version of the fonts installed, including Windows 10.)

\usepackage{winfonts}

\fontfamily{arial}\selectfont

You can also \renewcommand{\sfdefault}{arial} All the winfonts package itself does is change the encoding to T1, but including it will at least tell anyone trying to compile your document what package they need to install.

Another option is to use the original font on which Arial was based, Helvetica. Win points with typography snobs! TeX Gyre Heros is a very similar Helvetica clone. There is also Arimo.

  • imho the winfonts package no longer work with newer windows versions as glyph names in the fonts have changed, see e.g. tex.stackexchange.com/q/339253/2388. – Ulrike Fischer May 7 at 21:46
  • @UlrikeFischer Ah, okay. I think installing the older version of the fonts in a directory that your engine would search first would be a stopgap, but we can hope there’ll be an update to winfonts. – Davislor May 7 at 22:29
  • @UlrikeFischer Added a comment. Thanks for the reminder! – Davislor May 7 at 22:30
  • 1
    @TeXlearner I’m not sure what the issue is there, sorry. You might have some extra packages in your preamble. If you load fontspec, don’t also use fontenc, inputenc, uarial, winfotns, etc. – Davislor May 8 at 13:54
  • 1
    You can change the PDF viewer that TeXMaker uses. Also make sure it knows you’re compiling with XeLaTeX. – Davislor May 8 at 14:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.