3

I plan to use this document template for constructing my thesis: http://www.latextemplates.com/template/masters-doctoral-thesis

However, when running in draft mode, multiple rulers appear in the header and im unable to find whats causing them. Could someone explain why they are there and how to remove them?

regards, Phil

Rulers appear when using draft mode

6
  • I won't download a zip-file from an external site to debug it. See also tex.stackexchange.com/a/391022/2388. May 8, 2019 at 9:18
  • Welcome to TeX.SE! I have downloaded the zip file and ran it; it has no problems and these rulers were never shown. Can you please elaborate on how you achieved this result (in terms of you TeX distribution or did you use Overleaf). May 8, 2019 at 9:19
  • @M.AlJumaily the rulers only appear when draft mode is selected as an option in line 30 of the main.tex file and the rulers appear on page 3 onwards. I am compiling with texworks May 8, 2019 at 9:30
  • @esdd has the answer which works! May 8, 2019 at 9:35
  • Or you could just not use a KOMA document class. May 8, 2019 at 12:43

2 Answers 2

6

Your class loads package scrlayer-scrpage which adds the rulers if option draft is set. To disable the draft mode for package scrlayer-scrpage add \KOMAoptions{draft=false} to your preamble.

Example:

\documentclass[draft]{book}
\usepackage{scrlayer-scrpage}

\KOMAoptions{draft=false}% <- disables the draft mode for scrlayer-scrpage

\usepackage{blindtext}
\begin{document}
\blinddocument
\end{document}
3

The document class file contains this on line 278

\RequirePackage[markcase=used]{scrlayer-scrpage}

By changing to

\RequirePackage[markcase=used, draft=false]{scrlayer-scrpage}

It removes the rulers in draft mode.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .