0

I have a PNG file in the figure also graphicx package has been added. Still I get this error!

These are the packages/settings I am using:

\usepackage{myphdthesis}
\input epsf
\usepackage{cite}
\usepackage[export]{adjustbox}
\usepackage[colorlinks=false]{hyperref}
\usepackage{siunitx}
\usepackage{epstopdf}
\sisetup{per-mode=symbol}
\sisetup{separate-uncertainty,
  multi-part-units = single,}
\usepackage{textgreek}
\usepackage{nicefrac}
\usepackage{subfigure}
\usepackage{graphicx}
\usepackage[flushleft]{threeparttable}
\usepackage{rotating}

Can someone please help?

N.B.: The same code was successfully run few months ago in another machine with Windows 7 in TeXnic Center. Now I installed latex Miktex and TeXnic center in a Windows 10 environment.

  • 1
    Welcome to TeX.SE! From your error message it looks like you are running pdftex. You could try running pdflatex (LaTeX=>PDF) instead, see for example the screenshot at dataonlygreater.com/assets/images/TeXnicCenter_compile.png. – Marijn May 15 at 10:54
  • To me, it rather seems that the pdfTeX engine (maybe via the pdflatex.exe executable) is run in DVI mode while trying to include a PDF image, which isn't supported. Isn't the pdflatex.exe program called with -output-format dvi or something like that? In this case, try removing these options, or choose “generate PDF” instead of “generate DVI”, whatever the precise wording is in TeXnicCenter. – frougon May 15 at 12:36
  • Thanks. I tried pdflatex, but seems like it's having problem to generate the pdf file. I already have the latest GS installed. – ijamal May 15 at 13:41
  • EPSf about 30 years ago in a century long past was for use of EPS with dvips The orig­i­nal (and now ob­so­les­cent) graph­ics in­clu­sion macros for use with dvips, still widely used by Plain TeX users (in par­tic­u­lar) thus is current BUT. similarly {epstopdf} is considered redundant you are trying to force both to co-exist with graphicx png handlers. refresh your review of which one to use and discard the others – user170109 May 15 at 19:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.