0

This MWE produces a compile error:

\documentclass[12pt,letterpaper]{article}

\usepackage{pdfpages}
\usepackage{lipsum}

\title{My Title}
\author{First M. Last}

\begin{document}
\maketitle

\lipsum

\newpage
\includepdf{myPDF}

\end{document}

Here is the exact error message (line 15):

pdfTeX error (\pdfsetmatrix): Unrecognized format.. \includepdf{myPDF}

I am compiling with MiKTeX-pdfTeX 2.9.7029 (1.40.20) (MiKTeX 2.9.7000 64-bit). This is within TeXstudio on Windows 10. Does anyone know why I get this error or how fix/prevent/avoid it?

  • Sounds as if something is wrong with your myPDF. – Ulrike Fischer May 16 at 13:52
  • I suppose it does, but I've tried a lot of different PDFs created in different ways. Also, some of my coworkers can compile the code above, while others like me get the error message. It's not a one-time occurrence. This has gone on for over a year. – Jason May 16 at 14:43
  • Do you get the error with \includepdf{example-image-duck}? If yes show the log-file. If not you will have to make one of the problematic pdf available. – Ulrike Fischer May 16 at 15:21
  • Yes, I do get that error with \includepdf{example-image-duck}. Also, I posted the files (including the log) here: <drive.google.com/open?id=1mqWw6vTW6hLcQ5XygT0yk5dHPkIDoUE-> – Jason May 17 at 12:55
  • By the way, I tried the original code (with example-image-duck) on Overleaf, and it compiles without error. Here is the link to the project: <overleaf.com/read/nczfnrqsyvdw>. Somehow, Overleaf's compiler must be handling this different from MikTeX. – Jason May 17 at 12:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.