0

Using this code:

\RequirePackage[l2tabu,orthodox]{nag}
\documentclass[12pt,letterpaper,nofootinbib,notitlepage,tightenlines]{revtex4-1}
\linespread{2}
\usepackage[letterpaper,margin=1in,bottom=1in]{geometry}
\usepackage[T1]{fontenc}
\usepackage{lmodern}
\usepackage[utf8]{inputenc}
\usepackage[french]{babel}
\usepackage{microtype}
%\raggedbottom
\usepackage[bottom]{footmisc}
\renewcommand{\footnoterule}{\kern -1ex\rule{0.3\linewidth}{0.5pt} \\ 
\vspace{1ex}}
\usepackage{amsmath}
\pagestyle{plain}
\usepackage{setspace}
\usepackage{blindtext}
\usepackage{caption}
\captionsetup{font={small,stretch=1}}
%\usepackage[bottom,multiple]{footmisc}
\usepackage{graphicx}
\usepackage{bm}
\usepackage{amsmath}
\usepackage{amsfonts}
\usepackage{amssymb}
\usepackage{graphicx}
\usepackage{indentfirst}
\usepackage{lipsum}
\usepackage{float}


\newcommand{\forceindent}{\leavevmode{\parindent=8em\indent}}

\begin{document}



\begin{center}\section{THEORY \& HYPOTHESES}
\label{sec:analysis}

to create the following new section and, as you can see, when the code is compiled the outcome includes a large vertical space. The same thing does not occur for any of my other sections despite using the exact same code pattern.

enter image description here

I tried using a variety of \vspace commands but could not get anything to work.

  • Please provide small but complete document which reproduce your problem. Instead of real text you can use dummy text from package lipsum or blindtext. Form provided fragments it is impossible to say, what went wrong with your document. – Zarko May 19 at 21:49
  • Thank you, I edited my question. I am very new to latex and I did not write the original code so I am confused on how to shorten it in an appropriate manner. – Graham Streich May 19 at 21:54
  • 2
    @GrahamStreich you remove all the parts that don't make a difference, often doing so you discover a poor sequence / duplicate or rouge out of sync item just adding \lipsum[1] \end{center} \end {document} to your mwe I see No problem – user170109 May 19 at 21:57
  • I see. I do not know exactly how to do that...is there any general command for removing spacing? – Graham Streich May 19 at 22:25
  • if this is article for some journal, don't worry about this space. They will managed all formatting issues of article. This space is partly influenced by article content which follows this paragraph (is there some figure/table with placement option H?) and partly by used double spacing. For test try replace all option [H] with [ht]at your floats (figure/table) and remove \linespread{2} in preamble. – Zarko May 19 at 22:52
1
\documentclass[12pt,letterpaper,nofootinbib,notitlepage,tightenlines]{revtex4-1}
\linespread{2}
\usepackage[letterpaper,margin=1in,bottom=1in]{geometry}

\usepackage{blindtext}

\begin{document}

\blindtext

\begin{center}
\section{THEORY \& HYPOTHESES}
\label{sec:analysis}
\end{center}

\blindtext

\clearpage

\blindtext 

\section{THEORY \& HYPOTHESES}

\blindtext
\end{document}

A few pointers:

  1. Don't put \section inside a center environment. Look at the two pages produced by the code above side by side and you'll see that doing so creates extra space.

  2. Try \allowdisplaybreaks in the preamble.

  3. Try \raggedbottom in the preamble.

  4. If none of those work then post a complete example demonstrating your actual problem.

  • 1
    Thank you for your help! I'm learning a lot of Latex today. – Graham Streich May 20 at 1:00
0

I realized I could get around the formatting issues by explicitly separating the sections by placing a \newpage after the text of the section.

  • Use \clearpage instead of \newpage if you want the floats to stay with their section. – JPi May 20 at 1:14
  • What are floats? – Graham Streich May 20 at 3:42
  • 1
    Tables and figures – JPi May 20 at 10:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.