2

I am creating a beamer presentation with several plots and tikz figures. It takes a long time to compile and view. This is only amplified by the fact that texstudio apparently runs pdflatex and the bibliography several times. While this behavior is usually desirable, it is wasting a lot of time and I don't need to regenerate the bibliography to draft my slideshow. I could substantially speed up my compiles if I could get texstudio to ignore the bibliography. I did both of the following:

(1) comment out the code that creates bibliography slides (2) Options -> Configure Texstudio -> Build, and removed the bib commands from the command stream. However, it still tries to compile the bib and throws message boxes stating "Command txs:///bibliography not defined". So clearly it's still trying to take care of the bibliography.

I'm not sure what the MWE would be here. It's more of a texstudio question.

NOTE: I can avoid this problem by commenting out all the citations, but that is not an elegant or efficient lasting solution.

  • 1
    TeXstudio is notorious for adding extra background runs (that's one reason its popular as a common I just click and it worked until now editor) without seeing your command structure its tough to see why your neutering is not working but check if Tools commands pdfLaTeX just runs the one app – user170109 May 20 at 23:31
  • 1
    remove all commands in the pre-compile command and make sure that the small triangles besides the commands are not green but gray (click on them if they are green until they are gray); if they are green the command can run multiples times, if they are gray the command can only run once – wun May 21 at 11:11
  • @wun thanks, your comment led me to find the "Show Advanced Options" hidden at the bottom left, which I didn't see previously. – RMurphy May 21 at 16:37
2

The following yielded pretty substantial speed-ups for me. You may need to show advanced options: Options -> Configure texstudio -> Build -> click the "Show Advanced Options" in the bottom left

  1. Uncheck the box "Check and update bibliography before compiling".
  2. Change "Maximum compile repetitions" from 5 to 2.

When I'm done with my draft, I'll set these back. I still think it is nice to have texstudio handle all the final compilations.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.