0

I have specified 3 equation in tex file,

The font size of contents in each equation in the align environment appears to be different.Also, not all equations all aligned in the same way. Is there a way to specify same font size for all equations and align it in a nice way?

\documentclass{article}
\usepackage[utf8]{inputenc}
\usepackage{mathptmx}
\usepackage{amsmath}
\usepackage{makecell}

\title{Table}
\author{xx }
\date{May 2019}

\begin{document}

\vspace{1cm}
\large \textbf{1-D   equation:}\\
\begin{align*}
\large{ \hspace{2cm}\frac{\partial A}{\partial t} = 2\frac{\partial A}{\partial x}}
\end{align*}

\large \textbf{Equation 2:}\\
\vspace{1cm}
\small{ \textbf{Number = 2}}\\
\begin{align*}
\large{ X = CS = \frac{R}{8}\Delta G} 
\end{align*}
\vspace{0.5cm}
\large \textbf{Equation 3}\\
\vspace{0.5cm}
\small{ \textbf{Movement}}\\
\begin{align*}
\Large{\hspace{3cm}D_{q} = \frac{\big(\frac{CS}{40}\big)^2.5}{1256}} 
\end{align*}
\end{document}

EDIT: Updated code after making the changes suggested in the comment. The font size issue is resolved now. The problem is with the alignment of text and equations.

\documentclass{article}
\usepackage[utf8]{inputenc}
\usepackage{mathptmx}
\usepackage{amsmath}
\usepackage{makecell}

\title{Table}
\author{xx }
\date{May 2019}

\begin{document}

\vspace{1cm}
\large \textbf{1-D   equation:}\\
\begin{align*}
{\large \hspace{2cm}\frac{\partial A}{\partial t} = 2\frac{\partial A}{\partial x}}
\end{align*}

{\large \textbf{Equation 2:}}\\
\vspace{1cm}
{\small \textbf{Number = 2}}\\
\begin{align*}
\large X = CS = \frac{R}{8}\Delta G
\end{align*}
\vspace{0.5cm}
{\large \textbf{Equation 3}}\\
\vspace{0.5cm}
{\small \textbf{Movement}}\\
\begin{align*}
{\large\hspace{3cm}D_{q} = \frac{\big(\frac{CS}{40}\big)^2.5}{1256}} 
\end{align*}
\end{document}
2
  • 2
    Commands like \large or \small don't take an argument, they are switches that make their effect last until the currently active group is closed. Use {\large ...} etc. to limit the scope instead.
    – siracusa
    May 21, 2019 at 4:10
  • 1
    There are several other markup problems: 1) You shouldn't use \` as newlines, use \par` or an empty line instead. 2) align* is meant to align several equations at a common position, you are only using a single equation each. Perhaps you want equations instead? 3) There is a lot of manual spacing. Especially the \hspace in the align blocks makes the alignment look weird. For structuring your document, you should better use \section, \subsection etc. commands and remove the manual spacing.
    – siracusa
    May 21, 2019 at 4:27

1 Answer 1

1

You should adjust font sizes globally, for example via an option to the document class. Headings are best done with standard commands for consistency of style and spacing. You need to issue \maketitle to get your title and author printed.

Sample output

\documentclass[12pt]{article}

\usepackage{mathptmx}
\usepackage{amsmath}

\title{Table}
\author{xx}
\date{May 2019}

\begin{document}
\maketitle

\section*{1-D   equation:}
\begin{equation*}
  \frac{\partial A}{\partial t} = 2\frac{\partial A}{\partial x}
\end{equation*}

\section*{Equation 2:}
\subsection*{Number = 2}
\begin{equation*}
  X = CS = \frac{R}{8}\Delta G
\end{equation*}

\section*{Equation 3:}
\subsection*{Movement}

\begin{equation*}
  D_{q} = \frac{\bigl(\frac{CS}{40}\bigr)^2.5}{1256}
\end{equation*}
\end{document}
2
  • Thanks a lot. I'd like to know if there a way to align all = symbol,in the 3 equations, at the same position.
    – Natasha
    May 22, 2019 at 3:10
  • See tex.stackexchange.com/q/197698/15925 (place & before = instead at the beginning of the line) May 22, 2019 at 6:08

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .