2

I am quite new to LaTex... I am trying to change the font style of the citation of an @misc entry. When cited, it always appears italicized (in text as well as bibliography entry). My goal is that @misc entries do NOT appear italiciced/bold/in quotation marks. I need them to be "normal". (I have to use the apacite style it is manfatory for my thesis.) Please help, I am quite desperate ... :D

My MWE:

\documentclass[12pt, titlepage, a4paper, oneside]{scrreprt}


\usepackage{apacite}


\begin{document}
\urlstyle{same}

\bibliographystyle{apacite}
\setlength\bibitemsep{0.8\baselineskip}
\bibliography{references}
\urlstyle{same}

\end{document}

My Bibliography:

@misc{ARDBoerseTagessschau,
  title = {{ARD Boerse Tagesschau}},
  howpublished = {Retrieved May 15, 2019, from \url{https://www.tagesschau.de/wirtschaft/boerse/familienunternehmen-105.html}},
  year = {2019}
}

Many people recommend \DeclareFieldFormat. However, this did not work... What am I doing wrong?

1
  • Welcome to TeX.SE. – Mico May 22 '19 at 14:46
1

The typographic behavior you've noticed occurs because you didn't provide an author field for the entry, forcing the apacite package and associated bibliography style to display the title field in the citation call-out. And, as you've "discovered", the title field is set to be typeset in italics.

An inspection of the contents of https://www.tagesschau.de/wirtschaft/boerse/familienunternehmen-105.html suggests strongly that you should (a) change the name of the title field to author and (b) provide a new title field, viz., title = {Familienunternehmen sind {Jobmotor}},.

Observe that by writing author = {{ARD B{\"o}rse Tagesschau}}, i.e., by encasing the author's name in two pairs of curly braces, you inform BibTeX that it's dealing with a so-called "corporate" author and not with a person whose first given name is "ARD", whose middle name is "B{\"o}rse", and whose surname is "Tagesschau". This ensures that the entry will be sorted under A for "ARD" rather than under T for "Tagesschau", and also that the citation call-out will show "ARD Börse Tagesschau" and not just "Tagesschau".

enter image description here

\RequirePackage{filecontents}
\begin{filecontents}{references.bib}
@misc{ARDBoerseTagessschau,
  author       = {{ARD B{\"o}rse Tagesschau}},
  title        = {Familienunternehmen sind {Jobmotor}},
  urldate      = {May 15, 2019},
  url          = {https://www.tagesschau.de/wirtschaft/boerse/familienunternehmen-105.html},
  year         = {2019}
}
\end{filecontents}

\documentclass[12pt, titlepage, a4paper, oneside]{scrartcl}
\usepackage{apacite}
\bibliographystyle{apacite}
%\setlength\bibitemsep{0.8\baselineskip}
\usepackage{xurl}

\begin{document}
\cite{ARDBoerseTagessschau}
\urlstyle{same}
\bibliography{references}
\end{document}
4
  • Hi Mico, thank you so much for your quick help!! I tried your solution and it worked. However, using your solution creates a reference entry without dot (.) at the end. Is there a way to add the . ? Also, "Familienunternehmen sind Jobmotor" now is italic. This is much better than before. Unfortunately my professor does not want anything italicized when citing a webpage. Is it possible to suppress "Familienunternehmen sind Jobmotor" being italicized? Thank you so much for your help! – LaTexNewbie May 23 '19 at 9:33
  • @LaTexNewbie - I'm glad my answer was useful. About the absence of a period ("dot") at the end of a formatted entry: That's a purposeful setting of the apacite bibliography style. If your professor can't stand this setting, then he/she shouldn't be forcing you use apacite. About not rendering the contents of the title field in italics if (and only if?) the entry at hand is a webpage: I don't think there's a general setting for that in apacite. You'll have to hand-edit the title fields so that they show, say, title = {\textup{Familienunternehmen sind Jobmotor}},. – Mico May 23 '19 at 10:42
  • @LaTexNewbie - More about the absence of a period at the end of the formatted entry if the final field is url: That's purposeful in the sense that showing a period in such cases, i.e., immediately after a URL string, might cause some confusion over whether or not the period is part of the URL string. Again, this setting is very specific to the apacite bib style. If your professor can't abide this setting, he/she shouldn't be forcing you to emply this bib style. – Mico May 23 '19 at 10:52
  • Thanks again, Mico. Using \textup{} in the title field does the trick! :) I really dont know why my professor forces us to use apacite on the one hand and also wants us to change specific settings about this style... I am guessing that this is some guideline of his professorship and that he himself is not using LaTex. – LaTexNewbie May 23 '19 at 11:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.