1

After reading the official documentation I've tried to add a headsepline to a document but with much dismay so far.

Here is a MWE:

\documentclass[11pt, DIV=11, headings=small]{scrreprt}

\usepackage[automark, headsepline]{scrlayer-scrpage}

\clearpairofpagestyles  % Gets rid of the pagemark on the footer by resetting the pagestyle
                        % However, even without this the headsepline doesn't show
\pagestyle{scrheadings}
\lohead*{Author1, Author2}
\cohead*{Title}
\rohead*{\pagemark}

\begin{document}

\chapter{One}

TEST

\chapter{Two}

Tests

\end{document}

Is there another option I forgot to add to make this work? I am using XeTeX btw.

1 Answer 1

2

Chapter pages uses pagestyle plain by default. You have to add option plainheadsepline.

\documentclass[11pt, DIV=11, headings=small]{scrreprt}
\usepackage[automark, headsepline,
  plainheadsepline% <- added
]{scrlayer-scrpage}% sets pagestyle scrheadings automatically

\clearpairofpagestyles
\lohead*{Author1, Author2}% or \ihead{...}
\cohead*{Title}% or \chead{...}
\rohead*{\pagemark}% or \ohead{...}

\begin{document}
\chapter{One}
TEST
\chapter{Two}
Tests
\end{document}

Result:

enter image description here

1
  • Thank you so much for the quick answer! Learned something new and solved the problem, thanks!
    – tailse
    May 27, 2019 at 22:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.