1

I am trying to install ConTeXt Standalone on MacOS (Mojave, 10.14.5) using the instructions at Context Garden's Mac install page. Everything goes fine until the last big step. When I use

sh ./first-setup.sh --modules=all --engine=luatex

the instal proceeds for a while, but then hangs when it gets to the modules. The last thing displayed in the terminal is:

mtx-update      | run, rsync -rpztlv --delete  contextgarden.net::'minimals/current/modules/f-urwgaramond/
...
minimals/current/modules/t-visualcounter/' '/Users/Gavin/context/tex/texmf-modules'

I added ... to remove many, many modules in the list. The module I really need is t-tikz, so I tried installing with just that module, and failed in the same way.

I was able to successfully install ConTeXt Standalone without using the module flag. The install was successful and works, but I don't have TikZ, which I need. I've tried both a single user and system-wide install with the same failure.

It seems to me that this problem probably isn't at my end, since the rest of the install works, but I don't know. I would be happy to get the TikZ module another way if there is another method that works. I'd like to get all of the modules so that if I need something later, I've got it.

Any advice would be greatly appreciated! My UNIX knowledge is just slightly better than the "cut-and-paste this into terminal" level. (e.g. I've heard of rsync, but not sh.

  • 1
    No problem with your exact command line on Linux. – Henri Menke May 27 at 23:37
  • 1
    To manually install tikz, download tikz.tds.zip from ctan and unzip it in ~/texmf. – Aditya May 28 at 9:32
1

With Henri's and Aditya's help, I was able to solve my problem in two steps.

1) Update rsync. I was using the version of rsync provided with the MacOS, which was ancient. With an updated version the instructions the install with modules worked fine. Thanks to Henri for getting me to take another look at my end of the install process.

While the install went smoothly, TikZ still did not work. So...

2) Install TikZ using Aditya's link.

I'm not sure why I had to install manually after I installed all modules with rsync, but it worked.

Thanks everyone!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.