Quite contrary to my own answer here, I think that the default \spaceskip setting for Linux Libertine is rather unfortunate: seemingly, the shrink component is too high (and I end up getting to narrow spaces in tight lines). So my question is: what setting would you recommend, and how it should be achieved (\spaceskip is global for all fonts, and I'd like only to change the shrink component of a space in Linux Libertine). I am using XeLaTeX, and I don't know whether \fontdimens work as in vanilla [pdf][e]tex.

1 Answer 1


Bringhurst suggests the values for body text: m/3 (even better if you can keep it at m/4) for interword space, m/2 for maximum space, and m/5 for minimum space. He also feels strongly against using the extra space between sentences, so assume \frenchspacing.

Setting the \fontdimens work up until the math \fontdimens.

\spaceskip is meant for temporarily changing the values, like removing the stretch and shrink components in \raggedright, which keeps interword space at its optimal value constantly.

So the settings could be represented in TeX form as:

% when the font you want is active:
\fontdimen2\font=.25em % or .3333em
  • Could you post the lines of code needed here, so that people can copy and paste it to their documents? :)
    – Johannes
    Commented Mar 25, 2012 at 6:54
  • @Johannes: sure, done.
    – morbusg
    Commented Mar 25, 2012 at 7:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .