0

To preface I am a complete beginner using lyx to finish my thesis so please be patient with me.

I am using bibtex to place my references and then connecting this to my lyx file. Take for example the reference below. The lyx document has been set to Biblatex (natbib mode). When citing Shillers reference as in the screenshot it appears as (R. Shiller, 1989). It should be (Shiller, 1989). Why is it adding the the "R."?

enter image description here

marked as duplicate by moewe biblatex Jun 5 at 14:31

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Do you happen to have another Shiller in your biliography? In this case biblatex just tries to differentiate them. – Sergei Golovan May 28 at 10:30
  • 2
    See tex.stackexchange.com/questions/134535/…. You need to get LyX to load biblatex with the uniquenames=false option. – David Purton May 28 at 11:02
  • As David mentions for all we know you need to add uniquename=false to your biblatex options. Did that work for you? (Do you know how to do that with LyX? Go to Document > Settings > Bibliography and add uniquenames=false to Options under Citation Style). – moewe May 30 at 6:24
  • Voted to close as duplicate of the standard uniquename question. If you are having trouble getting this to work with LyX, just ping me and edit the question and I will vote to reopen. – moewe Jun 5 at 14:32