0

When compiling my Latex project using Texstudio in Windows 10 (using MiKTeX 2.9), I am getting the following warning:

Values of option `pdfpagelayout':(hyperref) * `SinglePage'(hyperref) * `OneColumn'(hyperref) * `TwoColumnLeft'(hyperref) * `TwoColumnRight'(hyperref) * `TwoPageLeft' (PDF 1.5)

The Latex code is as follows

%input macros (i.e. write your own macros file called MacroFile1.tex)
%\include{Macros/MacroFile1}
%\PassOptionsToPackage{pagebackref=true}{hyperref}
\documentclass[oneside,12pt]{CUEDthesisPSnPDF}

%Tables and Figures
\usepackage{tabu}
\usepackage{graphicx}
\usepackage{subfigure}
\usepackage{caption}
%\usepackage[showframe=true]{geometry}
\usepackage{changepage}
\usepackage{rotating}
\usepackage{tabularx}


%\setcounter{tocdepth}{3}
\usepackage{makeidx}  % allows for indexgeneration
\usepackage{amssymb,amsthm,amsmath}
\usepackage[ruled]{algorithm2e}
\usepackage[T1]{fontenc}
\usepackage[english]{babel}
\usepackage[utf8]{inputenc}
\usepackage{multirow}
\usepackage{wrapfig}
\usepackage{url}
\usepackage[usenames]{color}
\usepackage{underscore} 
\usepackage{longtable}
\usepackage{float}
\usepackage{enumitem}
\usepackage{tikz}
\usepackage{pgfplots}
\pgfplotsset{compat=1.8}
%\usepgfplotslibrary{patchplots}
\usepackage{xcolor}
%\usepackage{draftwatermark}
%\SetWatermarkScale{4}
%\SetWatermarkLightness{0.90}
\usepackage{color,soul}
\usepackage[framemethod=tikz]{mdframed}

% References
\usepackage{natbib}
\usepackage{bibentry}

% ADDED PACKAGES
\usepackage{adjustbox}
\usepackage{pgfplots}
\pgfplotsset{compat=newest}

\usepackage{hyperref}

\hypersetup{
    pdfpagelayout=OneColumn}


% Thickness of the border for fbox command
\setlength{\fboxrule}{0.0pt}

\newcommand\abs[1]{\left|#1\right|}
\captionsetup{compatibility=false}

\newcommand*\circled[1]{\tikz[baseline=(char.base)]{
        \node[shape=rectangle,draw,inner sep=1.5pt] (char) {#1};}}

\ifpdf
    \pdfinfo { /Title  (Some Title Here)
               /Creator (TeX)
               /Producer (pdfTeX)
               /Author (Name of the author)
               /CreationDate (D:20130624000000)  %format D:YYYYMMDDhhmmss
               /ModDate (D:20140624000000)
               /Subject (Some Subject)
               /Keywords (PhD, Thesis)}
    \pdfcatalog { /PageMode (/UseOutlines)
                  /OpenAction (fitbh)  }
\fi

\title{Title of the Document}

\ifpdf
  \author{\href{mailto:some@email.com}{\textbf{Author Name}}}
  \collegeordept{\href{http://www.school.com}{School of Computing Science}}
  \university{\href{http://www.school.com}{University}}
% insert below the file name that contains the crest in-place of 'UnivShield'
   \crest{\includegraphics[width=150mm]{UnivShield}}
\else
  \author{{\bf Name}}
%  \collegeordept{School of Computing Science}
%  \university{University}
% insert below the file name that contains the crest in-place of 'UnivShield'
% \crest{\includegraphics[bb = 0 0 292 336, width=120mm]{UnivShield}}
\fi
%
% insert below the file name that contains the crest in-place of 'UnivShield'
% \crest{\IncludeGraphicsW{UnivShield}{40mm}{14 14 73 81}}
%
\renewcommand{\submittedtext}{Submitted in fulfilment of the requirements for the Degree of}
\degree{\it Doctor of Philosophy (PhD)}
\degreedate{February 2019}

\ifpdf
    \collegeordept{\href{http://www.school.com}{School of Computing Science}}
    \university{\href{http://www.school.com}{University}}
\fi

% turn of those nasty overfull and underfull hboxes
\hbadness=10000
\hfuzz=50pt

% Put all the style files you want in the directory StyleFiles and usepackage like this:
%\usepackage{StyleFiles/watermark}


\begin{document}
%\language{english}

\renewcommand\baselinestretch{0.70} % \renewcommand\baselinestretch{1.2}
\baselineskip=18pt plus1pt

\newcommand\mentalnote[1]{{\color{red}#1}}

% A page with the abstract on including title and author etc may be
% required to be handed in separately. If this is not so, then comment
% the below 3 lines (between '\begin{abstractseparte}' and 
% 'end{abstractseparate}'), normally like a declaration ... needs some more
% work, mind as environment abstracts creates a new page!
% \begin{abstractseparate}
%       \input{Front/abstract}
% \end{abstractseparate}

% Using the watermark package which is in StyleFiles/
% and to remove DRAFT COPY ONLY appearing on the top of all pages comment out below line
%\watermark{DRAFT COPY ONLY}


\maketitle

%set the number of sectioning levels that get number and appear in the contents
\setcounter{secnumdepth}{3}
\setcounter{tocdepth}{3}

\frontmatter
\include{Front/copyright}
\include{Front/declaration}
\include{Front/abstract}
\include{Front/acknowledgements}
\tableofcontents
\listoftables
\listoffigures

%\printglossary  %% Print the nomenclature
\addcontentsline{toc}{chapter}{Nomenclature}


\mainmatter

\part{Introduction and Background}
\label{part1}
\chapter{Introduction}
\label{chapter1}
%\newpage
\input{Introduction/introduction}

\chapter{Background \texorpdfstring{\\}{} and Related Work}
\label{chapter2}
%\newpage
\input{Chapter2/Introduction}

\part{Part Name}
\label{part2}
\chapter{Chapter Name}
\label{chapter3}
%\newpage
\input{Chapter3/introduction}

\chapter{Chapter Name}
\label{chapter4}
%\newpage
\input{Chapter4/introduction}

\chapter{Chapter Name}
\label{chapter5}
%\newpage
\input{Chapter5/introduction}

\part{Part Name}
\label{part3}
\chapter{Chapter Name}
\label{chapter6}
%\newpage
\input{Chapter6/introduction}
.
.
.

\part{Conclusions}
\chapter{Conclusions and \texorpdfstring{\\}{} Future Work}
\label{chapter7}
%\newpage
\input{Chapter7/conclusion}
.
.
.    

\appendix
\include{Appendix/chapter6}
\include{Appendix/chapter6-traffic}


%\bibliographystyle{Classes/CUEDbiblio}
%\bibliographystyle{Classes/jmb}
%\bibliographystyle{plainnat} %this works with package natbib
%\bibliographystyle{Classes/jmb} % bibliography style
\bibliographystyle{plainnat} 
\renewcommand{\bibname}{Bibliography} % changes default name Bibliography to References
%\nocite{*}
\bibliography{References/citations} % References file
\addcontentsline{toc}{chapter}{Bibliography} %adds References to contents page

\end{document}

As you can see, I tried to add the pdfpagelayout option in the \hypersetup but it is not working. Any idea of what is going on here?

The hyperref.sty file can be found here

Many thanks in advance.

  • Thanks @KJO I have added the full latex code. I removed some personal information that I did not want to be online (email, name, university...). Take into account that this is the main file of a bigger project (PhD Thesis). As you can observe after \begin{document} there are few inputs of other text files. However, those files do not load any package, everything is loaded in this main file. I have also tried to load the Hyperref package just before the \begin{document} and didn't work either. – Salias May 29 at 23:43
  • Also, I have added the hyperref.sty file in PasteBin – Salias May 29 at 23:49
  • The latex command works fine and I am able to create a PDF out of it. However, the issue comes when I am trying to use the Convert to Html tool that comes with Texstudio. It is not working because the latex command was triggering those warnings and other errors. I managed to get rid of all the warning except this one. – Salias May 29 at 23:53
  • Anyhow, it is a very unusual warning and couldn't find anything online to solve it. So, either way, I found useful to post the issue here for the community. – Salias May 29 at 23:54
  • In Texstudio, go to Tools > Convert to Html (pasteboard.co/Ih0QDS5.jpg) – Salias May 29 at 23:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.