30

I set the Install Packages on the Fly setting to Yes and try to compile my document in Texmaker, but I still get the error File [...] not found, where [...] is the package I need. Basically, I need to manually install every package I use.

For example, I want to use the footmisc package. I put \usepackage[bottom]{footmisc}, and I get the error ! LaTeX Error: File 'footmisc.sty' not found.

Is this a known bug, or am I misunderstanding this feature?

  • You should keep the internet on and the repository address should be properly configured. Pl check them. – user11232 Mar 25 '12 at 0:41
  • Yep, you're right @Harish, just had to configure my connection to the repository. – Tianxiang Xiong Mar 25 '12 at 1:13
  • Just a note for the future, if you are using TexStudio or other IDEs on windows, open it with "run as an administrator" then packages will install "on the fly". – Dexter May 15 '18 at 5:15
26

You should first ensure that the internet is ON. Then Go to

Start>all programs>MikTeX 2.9>Maintainance (Admin)>Package Manager (Admin).

This window will popup

enter image description here

Click Repository to get

enter image description here

Hope now the things will be clear.

Similarly the

 Start>all programs>MikTeX 2.9>Maintainance (Admin)>update (Admin). 

should get you

enter image description here

Where you can select the source. Once it is done, the next time you can choose the second option i.e., Last used package repository if you have made the specific settings for a particular repository.

  • +1, but two remarks: 1) Afaik, MiKTeX is Windows-only, so your PS is redundant. 2) Why would it be preferable to select Last used package repository the second time? What advantage do you get over keeping the option Use the nearest package repository? – doncherry Mar 25 '12 at 2:03
  • @doncherry Thank you for noting. Yes PS is redundant. I removed it. Second option is only personal preference and nothing special about it. – user11232 Mar 25 '12 at 2:12
  • 3
    I was having the same problem as OP, but specifying a repository did not help. I'm using TeXworks. ! LaTeX Error: File `amssmyb.sty' not found. – asterac Mar 20 '15 at 2:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.