0

Quoted from https://en.wikibooks.org/wiki/LaTeX/Page_Layout#Page_size:

It will not have been immediately obvious - because it doesn't really cause any serious problems - that the default page size for all standard document classes is US letter.

I created a simple document like this:

\documentclass{article}
\begin{document}
Lorem
\end{document}

After I compile this into PDF with TeX Live, I always get A4 size output.

$ pdflatex foo.tex
$ identify -verbose foo.pdf | grep Print
  Print size: 8.26389x11.6944

I can reproduce this on Ubuntu and Mac. Is the Wikibooks wrong in this case? Does the output size default depend on the Tex Live defaults?

3
  • “US Letter” may be the overall default page size. However, depending on how TeXlive was installed on your system, a different system-specific default page size could have been set. Please tell us more about how TeXlive was installed on your system. – Mico May 31 '19 at 13:21
  • 1
    You have to change the setting with tlmgr, On MacTeX it's easier with TeX Live Utility. – egreg May 31 '19 at 13:21
  • @Mico apt-get install texlive on Ubuntu and brew install basictex on Mac. – Lone Learner May 31 '19 at 14:18
2

By default TeX Live is installed with A4 paper chosen by default.

If your environment requires US Letter paper, just run

tlmgr paper letter

with the appropriate privileges.

On macOS, you can use TeX Live Utility (provided you installed TeX Live as MacTeX): menu Configure > Change Paper Size…

1
  • Minor clarification on this: TeX Live Utility doesn't require you to have installed MacTeX or BasicTeX using an Apple Installer package, but you'll have to adjust the path to tlmgr manually. – Adam Maxwell Jun 1 '19 at 4:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.