3

Usually, I work LaTeX on Overleaf, but now I need to use it in my computer. I have TeXmaker and TeXStudio, but when I try to run the code that works perfectly in Overleaf, I get the error in the line 67:

! Package listofitems Error: the \expanded primitive is not provided by your TeX engine, listofitems v1.62 cannot work: loading listofitems v1.61.See the listofitems package documentation for explanation.Type H <return> for immediate help.... {\input listofitemsold.tex\relax\endinput}

I was reading the documentation of \listofitems, but I don't understand why my code needs it or why I'm getting that error. I added the \usepackage{listofitems}, that appears here: http://tug.ctan.org/macros/generic/listofitems/listofitems-en.pdf.

Even though, it doesn't work. I verified all my packages with MikTeX Package Manager, in accord to another question, but the package is installed and I don't know what else to do. I will show my preamble:

\documentclass[11pt]{report}

%% Language and font encodings
\usepackage[spanish, english]{babel}
\selectlanguage{spanish}
\usepackage[utf8x]{inputenc}
%% Sets page size and margins
\usepackage[top=3cm,bottom=3cm,left=3cm,right=3cm]{geometry}
%\baselineskip=10mm
\renewcommand{\baselinestretch}{1.3}

%% Useful packages
\usepackage{amsmath}
\usepackage{amsfonts}
\usepackage{graphicx}
\usepackage{mathrsfs}
\usepackage{imakeidx} %Tabla de Contenido
\usepackage{amsthm}
\usepackage{amssymb}
\usepackage[all]{xy}
\usepackage{tikz-cd}
\usepackage{mathdots}
\usepackage{bbm}
\usepackage{hyperref}
\usepackage{faktor}
\usepackage{thmtools}

% Títulos con Fuente distinta---------
%\usepackage{titlesec}
%\usepackage{titling}

% Specify different font for section headings
%\newfontfamily\headingfont[]{Gill Sans}
%\titleformat*{\section}{\LARGE\headingfont}
%\titleformat*{\subsection}{\Large\headingfont}
%\titleformat*{\subsubsection}{\large\headingfont}
%\renewcommand{\maketitlehooka}{\headingfont}
\usepackage{sectsty}
\allsectionsfont{\sffamily}

%----Definiciones con otra Fuente
%\declaretheoremstyle[headfont=\normalfont]{normalhead}

\theoremstyle{plain}
\newtheorem{theorem}{Teorema}[chapter]

\theoremstyle{definition}
\newtheorem{definitionx}[theorem]{Definici\'on}
\newenvironment{definition}
  {\pushQED{\qed}\renewcommand{\qedsymbol}{$\square$}\definitionx}
  {\popQED\enddefinitionx}

\newtheorem{examplex}[theorem]{Ejemplo}
\newenvironment{example}
  {\pushQED{\qed}\renewcommand{\qedsymbol}{$\triangle$}\examplex}
  {\popQED\endexamplex}

\theoremstyle{plain}
\newtheorem{lemma}[theorem]{Lema}
\newtheorem{corollary}[theorem]{Corolario}
\newtheorem{preposition}[theorem]{Proposici\'on}
\usepackage{listofitems}
%Here is the error, in the next one.
\theoremstyle{remark}
\newtheorem{note}[theorem]{Nota}
%------------------

\usepackage{subfiles}

\graphicspath{{images/}{../images/}}

\usepackage{stackengine}
\stackMath 

%% Definiciones
\DeclareMathOperator{\rep}{rep}
\DeclareMathOperator{\Hom}{Hom}
\DeclareMathOperator{\coker}{coker}
\DeclareMathOperator{\im}{im}
\DeclareMathOperator{\incl}{incl}
\DeclareMathOperator{\proj}{proj}
\DeclareMathOperator{\inj}{inj}
\DeclareMathOperator{\End}{End}
\DeclareMathOperator{\Ext}{Ext}
\DeclareMathOperator{\rad}{rad}

%------------------------------------------------------------------------
%------------------------------------------------------------------------
%----INICIO DEL DOCUMENTO------------------------------------------------
%------------------------------------------------------------------------
%------------------------------------------------------------------------

\begin{document}

Any help would be really really useful. Thanks.

3
  • 5
    Check for updates as user and as admin. Probably you didn't update the miktex binaries. Jun 2, 2019 at 18:44
  • 1
    @UlrikeFischer Updating all the packages worked. Thanks.
    – Mretn
    Jun 2, 2019 at 19:38
  • This shows a downside with using online resources such as Overleaf: you don't have control about upgrades to the software. TeX Live release 2019 provides several new features and listofitems is perhaps the first package that exploits them. I don't think that Overleaf is going to upgrade to TL 2019 shortly.
    – egreg
    Jun 2, 2019 at 21:12

1 Answer 1

4

The \expanded primitive was available in LuaTeX for many years, and was made generally available (in pdfTeX and XeTeX) in the TeX Live 2019 release. As Overleaf currently uses TeX Live 2017, it is not available in pdfTeX there.

2
  • Sorry, If possible could you explain it a bit more? Maybe the problem here is that I don't understand what is the \expanded primitive.
    – Mretn
    Jun 2, 2019 at 19:01
  • 1
    @Mretn A primitive is a 'build in' to an engine (pdfTeX, LuaTeX, ...): the older engines simply don't provide it
    – Joseph Wright
    Jun 2, 2019 at 19:18

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .