I am having an option clash for package textcomp, it happens with this code:



But only happens when those 3 packages are together, there is no problem if one is missing i.e., newtxtext + minted, minted + xwatermark or newtxtext + xwatermark works fine, but newtxtext + minted + xwatermark generates the error.

I tried adding \PreventPackageFromLoading{textcomp} before newtxtext, and it indeed work, but I don't know if this is affecting something in the background that I am not aware of. Anyone have a better solution for this?

  • 1
    Hi, thanks for the quick response, i tried adding [notextcomp] option to all three packages, but non of them accepte it, also, i think that would be the same effect that \PreventPackageFromLoading{textcomp} does, right? – kleiver carrasco Jun 3 '19 at 2:00
  • 1
    Don't use the xwatermark package. It (or more precisely the catoptions packages it loads) does curious things with the option list handling and is rather a pain. See e.g. tex.stackexchange.com/q/45818/2388 which is a similar problem. – Ulrike Fischer Jun 3 '19 at 7:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.