0

My supervisor asked me to change my thesis fontsize, ONLY the fontsize, not the font type. I don't know why nothing work. I tried:

    \documentclass[13pt, twoside, openright]{book}

but it seems to keep the 10pt fontsize. This is part of my code:

\documentclass[13pt, twoside, openright]{book}
\linespread{1.3} 
\usepackage[textheight=\textheight,textwidth=\textwidth,bindingoffset=3cm,vcentering]{geometry}
\usepackage{enumitem}
\usepackage[greek,english]{babel}
\usepackage[utf8]{inputenc}
\usepackage{graphicx}
\usepackage{sectsty,lmodern}
\usepackage{float} 
\usepackage{media9}

\usepackage[backend=biber,style=numeric, defernumbers=true]{biblatex}

\addbibresource{bib/references.bib}

\graphicspath{ {img/} }
\chapternumberfont{\fontsize{20pt}{18pt}\selectfont}
\chaptertitlefont{\fontsize{20pt}{18pt}\selectfont}
\addtolength{\skip\footins}{2pc plus 2pt}
\usepackage{fancyhdr}
\usepackage[begintext=“, endtext=”]{quoting}
\quotingsetup{vskip=2pt}
\pagestyle{fancyplain}
\fancyhf{}
\renewcommand{\headrulewidth}{0pt}
\renewcommand{\footrulewidth}{0pt}
\fancyfoot[LE,RO]{\thepage}
\usepackage[citecolor=black]{hyperref}
\hypersetup{
    colorlinks=true,
    linkcolor=blue,
    filecolor=magenta,      
    urlcolor=blue,
    bookmarks=true
}
\urlstyle{same}


\input{titlepage/Titlepage-Generic-Config}

\begin{document}
\frontmatter
\input{titlepage/Titlepage}
{
  \hypersetup{linkcolor=black}
  \clearpage
  \tableofcontents 
}

\mainmatter
\chapter*{Abstract}
...
\newpage
\printbibliography[keyword={biblio}, heading=bibintoc, title={Bibliography}]
\newpage
\printbibliography[keyword={site}, heading=bibintoc, title={Sitography}]

\end{document}
  • 1
    default supported font sizes in book are 10pt, 11pt, and 12pt. – naphaneal Jun 3 at 15:04
  • 1
    Try 12pt instead. 13pt is not a valid option. – StefanH Jun 3 at 15:04
  • I've already tried both 11pt and 12pt, it doesn't seem to change anything – Jojo Jun 3 at 15:05
  • 1
    @Jojo - If setting 11pt or 12pt instead of 10pt (the default for the book document class) changes nothing, then something may be very wrong with your TeX installation. – Mico Jun 3 at 15:44
  • Is there a class different from book with the same fontstyle but with a larger fontsize? – Jojo Jun 3 at 16:25
1

The memoir class (a superset of the book and report classes) provides options for font sizes ranging from 9pt to 60pt.

Regarding your MWE I couldn't run it properly because of missing titlepage files. However, ignoring those, changing the class fontsize option between 10pt and 12pt gave me, after I had added some normal (lipsum) text, different font sizes in the document.

I also ran my edited version of your MWE with the memoir class

\documentclass[14pt, twoside, openright]{memoir}

which can be simplified to

\documentclass[14pt]{memoir}

as twoside and openright are among the default options. It did come up with an error that The secsty package does not work with this document class. The memoir class provides its own methods for secsty like things.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.