1

Working with biblatex-chicago in the memoir class, for works with only an editor, I need "ed." not to be preceded by a comma in citations and bibliography. That is, instead of

Firstname Lastname, ed.

I'd like

Firstname Lastname ed.

Based on this answer and the biblatex manual, I tried

\renewcommand{\editortypedelim}{\space}

but this produced an error (\editortypedelim undefined), and I'm not even sure if that's the right thing to be modifying, so I'm not sure where to go from here.

MWE:

\documentclass[12pt]{memoir}

\usepackage[notes,shorthandibid,backend=biber,addendum=false,sorting=nyt,giveninits=true,useprefix=false,shorthandfull]{biblatex-chicago}

\usepackage{filecontents}
\begin{filecontents*}{jobname.bib}
@book{lastname98,
editor = {Firstname Lastname},
title = {A Book},
date = {1898},
address = {City},
}
\end{filecontents*}
\addbibresource{jobname.bib}

\begin{document}

Have a sentence.\autocite{lastname98}

\printbibliography

\end{document}
  • 2
    editortypedelim is a relatively recent addition to biblatex and it is not at all unlikely that some contributed styles may not have picked it up (some style like biblatex-chicago redefine a lot of things and will overwrite or ignore the predefined standard macros using editortypedelim). Note that editortypedelim is a context-sensitive delimiter (according to the manual) and thus should be redefined with \DeclareDelimFormat{editortypedelim}{...} and ideally not with \renewcommand{\editortypedelim}{...} (but the latter will work in simple cases). – moewe Jun 4 at 6:00
2

The biblatex-chicago style uses \editordelim (which is not in the manual) instead of \editortypedelim. If you redefine this the comma disappears:

\documentclass[12pt]{memoir}

\usepackage[notes,shorthandibid,backend=biber,addendum=false,sorting=nyt,giveninits=false,useprefix=false,shorthandfull]{biblatex-chicago}
\renewcommand{\editordelim}{\addspace}

\usepackage{filecontents}
\begin{filecontents*}{jobname.bib}
@book{lastname98,
editor = {Firstname Lastname},
title = {A Book},
date = {1898},
address = {City},
}
\end{filecontents*}
\addbibresource{jobname.bib}

\begin{document}

Have a sentence.\autocite{lastname98}

\printbibliography

\end{document}

enter image description here

Note that your MWE used giveninits=true which prints initials for the first name. In the code above this option is false which means the name is printed in full, but the last name is printed before the first name.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.