0

I'm seeing unexpected behaviour where using the quote environment permanently resets the margins/writing space (not sure what is technically happening) for the remainder of the document using documentclass scrlttr2. Each subsequent quote further reduces the writing space.

Is there a simple fix? Or is changing documentclass the best solution (annoying but I can mimic the set up another way I'm sure). See MWE and output below.

Screenshot of the output from the MWE

MWE:

\documentclass[fontsize=12pt, paper=a4]{scrlttr2}

% Dont forget to read the KOMA-Script documentation, scrguien.pdf

\setkomavar{fromname}{} % your name
\setkomavar{fromaddress}{Address \\ of \\ Sender}

\setkomavar{signature}{} % printed after the \closing
\renewcommand{\raggedsignature}{\raggedright} % make the signature ragged right

\setkomavar{subject}{} % subject of the letter

\begin{document}
\begin{letter}{Name and \\ Address \\ of \\ Recipient}

\opening{Dear}  % eg. Hello

Text that is formatted as expected \quote{something in quotes} \\

and then forever after I'm stuck with different indenting\\

Even many paragraphs later \quote{leading to subsequent quotes being even more indented}

and then being stuck even further indented

\closing{Regards} %eg. Regards

\end{letter}
\end{document}
  • 1
    unrelated but never use \\ at the end of a paragraph, it generates bad output and an underfull box warning – David Carlisle Jun 6 at 0:16
  • @DavidCarlisle what is your suggested way to force spacing between paragraphs? The only way I'm familiar with is \\ (perhaps with a length if required), which is what I have always used when I need space. – Esme_ Jun 6 at 5:30
  • \\ at the end of a paragraph does not add space it appends a spurious extra line to the paragraph as if you had gone \\ SPACE HERE but as the line is empty tex warns you it has badness 10000 (which is its maximum level of bad output) just leave a blank line in the source and specify that you want paragraphs offset with vertical space as a document class option to the koma classes, or using the parskip package. – David Carlisle Jun 6 at 6:38
  • Thanks for the explanation @DavidCarlisle. I think however with how I use them the parskip package actually doesn't have the same effect - as this varies the spacing between all paragraphs rather than specific ones. Likewise - leaving a blank line leaves some space between paragraphs, but not the extra space I am looking for (I'm usually using both, or specifically using \[3cm]. Experimenting a bit, it seems you can remove the badness warning by using \\~\phantom{stuff}, which I guess would be a better option. Thanks for making me aware of this – Esme_ Jun 10 at 6:06
  • \\~\phantom{stuff}, is even worse than simple \\ as you still get the bad output but no warning. Either way you are not getting vertical space but a "white line of text" this for example will not be dropped at a page break so you will get pages starting one line too low. – David Carlisle Jun 10 at 6:48
2

as you note in the title quote is an environment so has syntax

\begin{quote}
stuff here
\end{quote}

not \quote{stuff here} However that just indents a block quote, you seem to want an inline quotation with quote marks, so the markup should be

``stuff here''
  • 1
    this is unrelated to the document class, you would see the same behaviour in article or any of the standard classes. – David Carlisle Jun 6 at 0:17
  • This seems generally undesirable behaviour (perpetually indenting the rest of the document repeatedly) so I did a bit more searching and found the explanation that \quote is an internal definition that was never meant to be used directly. – Esme_ Jun 6 at 5:10
  • No quotation marks wanted - the format from \quote{} was what I was after, just without the effect on the rest of the document. – Esme_ Jun 6 at 5:11
  • @Esme_ the behaviour isn't undesirable or specific to quote: you started a quotation but didn't end it so it lasts until the end of the document. You would see the same if you replaced \quote by \bfseries the rest of the document would go bold, or \large or \color{red} etc. – David Carlisle Jun 6 at 6:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.