0

This question already has an answer here:

I have saved some references in a library.bib file, using JabRef. One of these entries is the following:

@Article{Feng2014, 
    author = {Bo Feng, Mengyin Fu, Hongbin Ma, Yuanqing Xia, Bo Wang},
    title = {Kalman filter with recursive covariance estimatio - sequentially estimating process noise covariance}, 
    journal = {IEEE Transactions on Industrial Electronics},
    year = {2014}, 
    volume = {61},
    number = {11},
    pages = {6253-6263}
}

Now I want to include citations in my TeX-document:

\documentclass{article}  
\usepackage[backend=biber,citestyle=ieee,sorting=none,dateabbrev=false,urldate=comp]{biblatex}
\addbibresource{./library.bib}
\begin{document}
\section{First Section}
Equations given in this section have been taken from \cite{Feng2014} and
\printbibliography[heading=bibintoc]
\end{document}

I am running PDFLaTeX, Biber, PDFLaTex, PDFLaTeX. The references should be included as numbers, such as [1], wherever the citation is used. Instead of the number, however, the name of the BibTeX-key is given. And the reference is not included in the bibliography.

I have tried to make this a MWE. When I run this code now, the bibliography is not printed at all and the reference within the text is given as the BibTeX-key.

marked as duplicate by moewe biber Jun 9 at 20:56

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 1
    As always on this site: If you want other to help you then please post a full but minimal example. This is just a preamble (where a lot of stuff are irrelevant for your question). That way others can easily copy your example and test it out. As it sits now, we have to fill in several details, which often causes others on pass on a question like this. – daleif Jun 7 at 10:34
  • @daleif: Ok, I have tried to make this an MWE now. I am using a customized template, so things are a little bit different for me. But the problem arises with this given example as well. – user503842 Jun 7 at 12:15
  • Are you sure the bib data is suppose to be provided like that? Doesn't biblatex normally use \addbibresource? – daleif Jun 7 at 12:18
  • whops, you're right. This is how it is included in my document as well. But it doesn't solve the issue – user503842 Jun 7 at 12:30
  • The name format is wrong. Regardless of the desired output all names must be separated with and a comma may only be used to separate name parts as in Family, Given and von Family, Jr., Given. You probably want author = {Bo Feng and Mengyin Fu and Hongbin Ma and Yuanqing Xia and Bo Wang},. See tex.stackexchange.com/q/36396/35864 and tex.stackexchange.com/q/557/35864 – moewe Jun 7 at 15:12

Browse other questions tagged or ask your own question.