I am trying to follow this answer so that I can use pdflatex. However I am having trouble.

While following the linked question, I first installed BasicTeX, then I started a new terminal. However I am still unable to find pdflatex. Here is my console currently:

➜  ~ brew cask install basictex
Warning: Cask 'basictex' is already installed.

To re-install basictex, run:
  brew cask reinstall basictex
➜  ~ which pdflatex
pdflatex not found
➜  ~    

I also tried adding it to my path, here is my path:


However that didn't work either, I started a new terminal and when I run which pdflatex I am still get pdflatex not found.

I have also tried this path with no luck:

  • 2
    Firstly, do you have the program actually installed — if you manually specify the path like /Library/TeX/texbin/pdflatex somefile.tex, does it work? If so, then you just need to add /Library/TeX/texbin/ (not /Library/TeX/texbin/pdflatex) to your PATH in your .bashrc or whatever. – ShreevatsaR Jun 13 at 0:42
  • I'm not sure why you're doing this with Homebrew in the first place. Also, unless you're really pushed for space, it's a lot simpler to install the full install instead of BasicTeX. I would simply get Homebrew to uninstall and start over using the installed from here: tug.org/mactex – Alan Munn Jun 13 at 1:27
  • 1
    what does whereis pdflatex return? – naphaneal Jun 16 at 11:35
  • there's this HowTo: pages.uoregon.edu/koch/BasicTeX.pdf – naphaneal Jun 16 at 13:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.