1

New linux (mint) user, with pdfTeX, Version 3.14159265-2.6-1.40.18 (TeX Live 2017/Debian), using TexStudio (that might change)

I have custom files (sty's and whatnot) in a folder that I cannot move (shared with other computers) that I would like to be able to \include or \input in all my tex files (including when I use TexStudio or another editor with building capabilities).

On windows, I'm able to create an environment variable TEXINPUTS to include that folder on latex (miktex) search path. On linux mint I tried (failed) the following :

  • directly in a terminal with export TEXINPUTS=~/Dropbox/Templates//: (only works inside said terminal)
  • Adding the previous line in .bashrc, .profile and /etc/environment. The first one made it work in any terminal.

Now it works in TexStudio if I launch TexStudio from any terminal. But not if I launch it from GUI. Is there a file I'm missing that could affect GUI launched applications ? Barring that a way to make it like texstudio was launched from a terminal ?

I also looked into :

There is supposed to be a texmf folder I can put files in, so I figured I could put a symbolic link to my folder there, but :

  • I haven't done a symbolic link in ~ 15 years
  • I can't find said texmf folder...

(apparently that would be bad)

Any help welcome !

  • export TEXINPUTS=/Dropbox/Templates//: will work (in that terminal session) as long as you are using bash or similar shell if (for some reason) you are using csh it would be setenv rather than export. Once you get it working iteractively you can put the appropriate line in your .bash_profile or similar setup file (get back to that later once the commandline setting works) – David Carlisle Jun 9 at 9:04
  • 1
    is Dropbox really at the root of your filesystem? – David Carlisle Jun 9 at 9:06
  • ok, my bad it is not at the root but inside ~. ~/Dropbox/Templates//: works indeed in the terminal session (i'm still a bit confused by ~). But only inside the terminal, not inside texstudio – imj Jun 9 at 9:40
  • ~ is your home directory usually /home/imj/ or some such. texstudio (if launched from your desktop) will not be in a shell below the terminal in which you made the interactive setting, you will need to add the line to your .bash_profile (and re-start) or (most likely) texstudio will have a setting within its own configuration (but I don't have texstudio so I'll leave others to answer) – David Carlisle Jun 9 at 9:43
  • 1
    @KDO Yep. I make a full backup from time to time, and as not all three computers are connected at the same time I can boot without network to get the local version in case it gets corrupted/missing from the cloud. – imj Jun 9 at 12:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.